This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 76732 - libelf-devel should be prerequisite for rpm-4.2.0-4.src.rpm
libelf-devel should be prerequisite for rpm-4.2.0-4.src.rpm
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-25 12:27 EDT by Ken MacFarlane
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-25 12:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken MacFarlane 2002-10-25 12:27:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020911

Description of problem:
The source rebuild of rpm fails if libelf-devel is not present.  Specifically,
build fails trying to find files libelf/libelf.h and libelf/gelf.h.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -e libelf-devel
2. rpmbuild --rebuild rpm-4.2-0.4.src.rpm

	

Actual Results:  creating rpmcache
source='striptofile.c' object='striptofile.o' libtool=no \
depfile='.deps/striptofile.Po' tmpdepfile='.deps/striptofile.TPo' \
depmode=gcc3 /bin/sh ../depcomp \
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I.. -I../build -I../lib -I../rpmdb -I../rp
mio -I../popt -I../elfutils/libelf -I../elfutils/libdwarf -I../zlib -I../zlib -I
../misc    -O2 -march=i386 -mcpu=i686 -D_GNU_SOURCE -D_REENTRANT -Wall -c `test
-f 'striptofile.c' || echo './'`striptofile.c
striptofile.c:4:27: libelf/libelf.h: No such file or directory
striptofile.c:5:25: libelf/gelf.h: No such file or directory
In file included from striptofile.c:8:
sections.h:4:25: libelf/gelf.h: No such file or directory


Expected Results:  rpmbuild completes successfully.

Additional info:
Comment 1 Jeff Johnson 2002-10-25 12:39:05 EDT
libelf-devel is not a build prereq because
rpm has an internal copy of elfutils in rpm-4.2
that will be used. No, libelf-devel is not adequate.

The rationale for this apparent bloat is that
the gelf API used by rpm (to preserve MD5 checks for
prelinked DSO's, and to generate dependencies) is not
(yet) widely available, prereq's will be added if/when
that time comes.

Note You need to log in before you can comment on or make changes to this bug.