Bug 767337 - Gnome Top Panel Invisible Intermittently
Gnome Top Panel Invisible Intermittently
Status: CLOSED DUPLICATE of bug 802069
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 15:36 EST by Robert Weir
Modified: 2012-03-20 22:01 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-20 16:14:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Weir 2011-12-13 15:36:01 EST
I had posted this at the gnome bugzilla and received the following reply, hence my current bug submission --->

--- Comment #4 from Ray Strode [halfline]<rstrode@redhat.com>  2011-12-12 21:37:03 UTC ---
Hi,

This is very likely a display driver issue and so we won't be able to help.

Can you file the bug at bugzilla.redhat.com? You should file the bug against
either xorg-x11-server or xorg-x11-drv-nouveau 
<----

Version-Release number of selected component: xorg-x11-server-Xorg.x86_64         1.11.2-3.fc16  and     xorg-x11-drivers.x86_64             7.4-2.fc15


I installed F16 on a HP Laptop.  The install went well and initially worked well.  Now after logging in as a user the (very important) text and icons on the top panel is scrambled.
Since the entire usage of Gnome 3 starts on this Top Panel, usage of the system is difficult to impossible.  I know where the items are and if I use the mouse they are still active.  The issue seems to be only rendering, in a visible fashion.

How reproducible:  This is reproducible every login where this unit is concerned. I have successfully installed on another Laptop and I do not have this problem at all.

Steps to Reproduce:  
1.  Logout as a user.
2.  Log back in.
3.  Problem is back.
4:  Log out as a user and restart computer
5:  Login as user and problem is back.

Actual results:  Top Panel Unusable!

Expected results: Top Panel Usable.

Additional info:
Comment 1 Robert Weir 2011-12-13 19:39:51 EST
xorg-x11-drv-nouveau.x86_64         1:0.0.16-27.20110720gitb806e3f.fc16
This is the version of the nouveau I missed before.
The Laptop is a HP DV6000.
Comment 2 Robert Weir 2011-12-29 13:06:04 EST
I am not sure if this bug has been viewed by anyone who could acknowledge it?
Comment 3 Philip Heron 2012-01-02 11:30:57 EST
I believe one of my machines is suffering the same issue. I've taken a couple of screenshots of my desktop after logging in:

http://www.sanslogic.co.uk/files/gnomeshell-bug1.png
http://www.sanslogic.co.uk/files/gnomeshell-bug2.png

Using driver:
xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64

The video chip is an onboard nvidia:
nVidia Corporation C68 [GeForce 7025 / nForce 630a] (rev a2)
Comment 4 Robert Weir 2012-01-02 13:29:53 EST
(In reply to comment #3)
> I believe one of my machines is suffering the same issue. I've taken a couple
> of screenshots of my desktop after logging in:
> 
> http://www.sanslogic.co.uk/files/gnomeshell-bug1.png
> http://www.sanslogic.co.uk/files/gnomeshell-bug2.png
> 
> Using driver:
> xorg-x11-drv-nouveau-0.0.16-27.20110720gitb806e3f.fc16.x86_64
> 
> The video chip is an onboard nvidia:
> nVidia Corporation C68 [GeForce 7025 / nForce 630a] (rev a2)

Hi Philip
  Yes that is exactly the problem I am having.  It is on a friends machine and as such I cannot get the specifics on Video Hardware.  I am pleased that you have posted here.  
  Is your problem intermittent or constant?  Mine can change between logons.
Cheers...
Robert
Comment 5 Philip Heron 2012-01-02 13:56:21 EST
Every time so far. I've noticed these in the logs, possibly unrelated:

Jan  2 16:18:49 spooky kernel: [   26.756171] [drm] nouveau 0000:00:12.0: fail t
tm_validate
Jan  2 16:18:49 spooky kernel: [   26.756178] [drm] nouveau 0000:00:12.0: valida
te vram_list
Jan  2 16:18:49 spooky kernel: [   26.756184] [drm] nouveau 0000:00:12.0: valida
te: -12
Comment 6 Philip Heron 2012-01-03 06:19:08 EST
Spoke too soon, after a power cut the machine loaded gnome-shell fine. There are no visual glitches at all this time.

The nouveau log messages I included in my last comment are still present.
Comment 7 Robert Weir 2012-01-03 11:17:13 EST
(In reply to comment #6)
> Spoke too soon, after a power cut the machine loaded gnome-shell fine. There
> are no visual glitches at all this time.
> 
> The nouveau log messages I included in my last comment are still present.

OK.  What do you mean "after a power cut"?  My problem is intermittent, so see if it returns over the next while.
Comment 8 Philip Heron 2012-01-03 11:34:02 EST
Strong winds overnight knocked the power off, when I switched it on again the next morning gnome-shell was working fine. I've since rebooted it and the glitches are back. So it is definitely intermittent.
Comment 9 Robert Weir 2012-01-03 11:46:30 EST
Yes.  My friends machine is OK sometimes, but unreliable.  Thanks for confirming that.  I cannot confirm the messages log as I do not have access to the machine but when I get access I will check.
Cheers...
Comment 10 Robert Weir 2012-01-11 12:15:07 EST
  One thing that I noticed, that is perplexing, is that the Top Panel is OK at the Login page.  This I understand is the Gnome Display Manager and not the Desktop Manager, but it is interesting that the Login Screen renders OK and the Desktop does not.
  I was unable to find any error messages with regards to 'nouveau' on my friends laptop.  Where exactly did you find those messages?
  I ran all updates up to yesterday and still no joy.  Hope this issue will get resolved soon.
Comment 11 Robert Weir 2012-02-07 12:20:16 EST
I have discovered what the one common ingredient is when the Top Panel borks.  It only borks on machines with nVidia Video cards and not on ATI.
I thought that F16 could run from one basic install on either Video Card Manufacturer's cards but I am wrong.  It cannot.
Comment 12 Robert Weir 2012-02-09 17:25:32 EST
Hi
  I was able to recreate this condition on a Desktop with a nVidia Corp nv34 [GEForce FX 5500] (rev a1).
  Hopefully this can help with your endeavors...
Robert
Comment 13 Adam Williamson 2012-03-20 16:14:35 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 745202 ***
Comment 14 Adam Williamson 2012-03-20 22:01:21 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 802069 ***

Note You need to log in before you can comment on or make changes to this bug.