Bug 767374 - Tiny bug in Pika 0.9.5
Summary: Tiny bug in Pika 0.9.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pika
Version: el6
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
Assignee: Ilia Cheishvili
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-13 22:05 UTC by Dan Aharon
Modified: 2016-02-13 19:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-13 19:21:21 UTC


Attachments (Terms of Use)
A slightly modified python-pika package that includes the BlockingConnection patch. (81.74 KB, application/x-rpm)
2011-12-13 22:05 UTC, Dan Aharon
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1244505 None None None Never

Internal Links: 1244505

Description Dan Aharon 2011-12-13 22:05:40 UTC
Created attachment 546422 [details]
A slightly modified python-pika package that includes the BlockingConnection patch.

Description of problem:
Pika 0.9.5 has a tiny import bug in it.

Version-Release number of selected component (if applicable):
1

Steps to Reproduce:
1.  Have a timeout from a BlockingConnection.
  
Additional info:
I created a trivial patch and updated the spec file.

Comment 1 Ilia Cheishvili 2011-12-19 18:54:16 UTC
Has this been fixed (In reply to comment #0)
> Created attachment 546422 [details]
> A slightly modified python-pika package that includes the BlockingConnection
> patch.
> 
Has this been fixed in the GitHub repo?
https://github.com/pika/pika/commits/master

I noticed that upstream is no longer tagging point releases (or at least they have not for 9 months), so if this is fixed in the GitHub project, it may be a better idea to simply start packaging off the head of the master branch.

Comment 2 Dan Aharon 2011-12-19 19:02:28 UTC
This has been fixed in the Github repo.
I did not update to the master branch because I do not know what the status of the project is right now.  There are recent commits in master, as well as a branch called pika2.

I figured I would just stick with this official release.  Once they tag the next stable release, whether it's pika 0.9.6 or 1.0.0 or 2.0.0, I figured the trivial patch can be removed.

Comment 3 Ilia Cheishvili 2011-12-19 19:14:13 UTC
(In reply to comment #2)
> I figured I would just stick with this official release.  Once they tag the
> next stable release, whether it's pika 0.9.6 or 1.0.0 or 2.0.0, I figured the
> trivial patch can be removed.

Fair enough--that makes sense.  I will look into accepting your patch this week (my Fedora machine had a hardware failure and it will take me a bit of time to get a new one :)

Comment 4 Dan Aharon 2011-12-19 19:19:01 UTC
Thanks.
I guess if it's going to take that long I can get in touch with the maintainer and convince him to do a minor release that fixes that bug...

Comment 5 Fedora Update System 2012-02-27 03:16:53 UTC
python-pika-0.9.5-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-pika-0.9.5-3.fc17

Comment 6 Fedora Update System 2012-02-27 03:17:30 UTC
python-pika-0.9.5-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-pika-0.9.5-2.fc16

Comment 7 Fedora Update System 2012-02-27 03:17:56 UTC
python-pika-0.9.5-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-pika-0.9.5-2.el6

Comment 8 Fedora Update System 2012-03-06 20:27:35 UTC
python-pika-0.9.5-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-03-08 05:04:53 UTC
python-pika-0.9.5-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2012-03-15 19:56:21 UTC
python-pika-0.9.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Raphael Groner 2016-02-13 19:21:21 UTC
Bodhi forgot this bug. Closing. Feel free to reopen if there's still any issue.


Note You need to log in before you can comment on or make changes to this bug.