Bug 76741 - External tools: project_loc?
External tools: project_loc?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-25 13:24 EDT by Keith Seitz
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 17:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Seitz 2002-10-25 13:24:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I was playing around with the external build tool dialogs, and I thought that I
could create a single external build tool for configure if I could specify:

name of tool to run: ${project_loc}/src/configure
arguments: --prefix=${project_loc}/built
--exec-prefix=${project_loc}/built/H-i686-pc-linux
working directory ${project_loc}

Unfortunately it appears that there are bugs dealing with the variable
"project_loc". Only workspace_loc appears to work. (project_loc is real: see #6
below)

Need to investigate this before submitting to eclipse.org.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Go to CVS Repository perspective, add sources.redhat.com as server, check out
the "gdb" module.
2. Go to C/C++ perspective. Add new C project, and choose "Convert to C
project". Select "src" when it appears in list.
3. Rename "src" in navigator view to "sources-gdb".
4. Create new "src" folder in "sources-gdb" and copy all the source files there.
(You'll need to move the toplevel CVS folder by hand.)

You should now have a directory layout that looks like:
$ ls workspace
sources-gdb
$ ls workspace/sources-gdb
src

5. configure an external build tool, "configure". Use tool name, arguments, etc
listed in description.
6. Select "Browse options" for Working Directory and select "selected resoure's
project directory". This inserts "${project_loc}" into entry widget.
7. run this "configure" tool

	

Actual Results:  It will create the build tree (Makefiles, etc) somewhere, not
in project dir. In fact, most of the time, project_loc is undefined. You can
tell because it used the working directory as workspace/.. (for me, that's my
eclipse root dir, ~/eclipse/workspace/..); looking at config.status, you can see
that --prefix=/built, so "x${project_loc}" = "x".

Expected Results:  Should have substituted project_loc=${workspace_loc}/sources-gdb

Additional info:
Comment 1 Keith Seitz 2004-08-03 17:21:48 EDT
The "project_loc" stuff seems to work now (although one still cannot
use Eclipse to develop anything on sources.redhat.com). I'm closing
this PR.

Note You need to log in before you can comment on or make changes to this bug.