This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 76742 - no way to abort any tool in CDT
no way to abort any tool in CDT
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: CDT (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-25 13:29 EDT by Keith Seitz
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 17:29:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Keith Seitz 2002-10-25 13:29:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
If I run any kind of tool in the CDT (build/make or external build tool like
configure), it cannot be aborted. It must complete. This is especially painful
if one forgets to select the "stop on error" option of the build preferences for
a project.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create external build tool to run configure (for example)
2. run this tool.
3. before it finishes, click "cancel"... The button is disabled, but nothing
really happens until the tool finishes executing.

Do the same for building a project.

Actual Results:  It just keeps on going and going and going.

Expected Results:  Should have stopped.

Additional info:
Comment 1 Jeremy Handcock 2003-11-19 17:13:32 EST
See upstream bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=41752

This is an eclipse platform issue rather than a CDT one.  I'll move
the upstream PR to the proper eclipse.org component.
Comment 2 Keith Seitz 2004-08-03 17:29:31 EDT
Well, this, too, seems to be rectified with the Eclipse 3.0/CDT 2.0
release. Yeah!

Note You need to log in before you can comment on or make changes to this bug.