Bug 767492 - The plugin doesn't delete zone when it is deleted in LDAP and zone_refresh is set
Summary: The plugin doesn't delete zone when it is deleted in LDAP and zone_refresh is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: IDM QE LIST
URL: https://fedorahosted.org/bind-dyndb-l...
Whiteboard:
Depends On:
Blocks: 767486
TreeView+ depends on / blocked
 
Reported: 2011-12-14 08:16 UTC by Adam Tkac
Modified: 2015-05-20 15:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:51:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0837 normal SHIPPED_LIVE bind-dyndb-ldap bug fix and enhancement update 2012-06-19 20:49:06 UTC

Description Adam Tkac 2011-12-14 08:16:02 UTC
Description of problem:
The plugin doesn't delete zone when zone_refresh parameter is set and zone disappears in LDAP.

Version-Release number of selected component (if applicable):
bind-dyndb-ldap-0.2.0-7.el6

Steps to Reproduce:
1. set zone_refresh parameter
2. add zone to LDAP (ipa dnszone-add)
3. wait for zone_refresh timeout and verify that zone is served by the named
4. delete zone (ipa dnszone-del)
5. wait for timeout, zone should be deleted
  
Actual results:
zone is no longer served

Expected results:
zone is served

Comment 4 Jenny Severance 2012-04-24 18:53:02 UTC
verified ::

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipa-dns-172 Bug 767492 - The plugin doesn't delete zone when it is deleted in LDAP and zone_refresh is set
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   LOG    ] :: verifies https://bugzilla.redhat.com/show_bug.cgi?id=767492
:: [   PASS   ] :: Running 'ipa dnszone-add unknownexample.com --name-server=dhcp-185-247.testrelm.com --admin-email=admin@unknownexample.com'
:: [   PASS   ] :: Running 'ipa dnszone-mod unknownexample.com --refresh=30'
:: [   PASS   ] :: Running 'ipa dnsrecord-add unknownexample.com foo --a-rec=10.0.2.2'
:: [   PASS   ] :: Running 'dig +short -t A foo.unknownexample.com | grep 10.0.2.2'
:: [   PASS   ] :: Running 'ipa dnszone-del unknownexample.com'
:: [   PASS   ] :: Running 'ipa dnszone-find unknownexample.com'
:: [   PASS   ] :: Running 'dig +short -t A foo.unknownexample.com | grep 10.0.2.2'
:: [   LOG    ] :: Duration: 1m 22s
:: [   LOG    ] :: Assertions: 7 good, 0 bad
:: [   PASS   ] :: RESULT: ipa-dns-172 Bug 767492 - The plugin doesn't delete zone when it is deleted in LDAP and zone_refresh is set


version ::
ipa-server-2.2.0-11.el6.x86_64

Comment 6 errata-xmlrpc 2012-06-20 13:51:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0837.html


Note You need to log in before you can comment on or make changes to this bug.