Bug 767530 - [abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
[abrt] ibus-1.4.0-11.fc16: __GI_raise: Process /usr/bin/ibus-daemon was kille...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
abrt_hash:8460ecba0f12e79efa6718122ae...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 05:07 EST by joona.jarvela
Modified: 2012-03-18 21:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-18 21:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (8.87 KB, text/plain)
2011-12-14 05:07 EST, joona.jarvela
no flags Details
File: smolt_data (3.17 KB, text/plain)
2011-12-14 05:07 EST, joona.jarvela
no flags Details
File: backtrace (34.85 KB, text/plain)
2011-12-14 05:08 EST, joona.jarvela
no flags Details

  None (edit)
Description joona.jarvela 2011-12-14 05:07:53 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/ibus-daemon -r --xim
crash_function: __GI_raise
executable:     /usr/bin/ibus-daemon
kernel:         3.1.4-1.fc16.x86_64
pid:            1967
pwd:            /tmp
reason:         Process /usr/bin/ibus-daemon was killed by signal 6 (SIGABRT)
time:           ke 14. joulukuuta 2011 11.57.08
uid:            1000
username:       joona

backtrace:      Text file, 35690 bytes
maps:           Text file, 9080 bytes
smolt_data:     Text file, 3250 bytes

dso_list:
:/lib64/libdl-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/lib64/libpthread-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/lib64/libgthread-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/usr/lib/locale/locale-archive glibc-common-2.14.90-21.x86_64 (Fedora Project) 1323615784
:/usr/lib64/libibus-1.0.so.0.400.0 ibus-libs-1.4.0-11.fc16.x86_64 (Fedora Project) 1323473639
:/lib64/libglib-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/lib64/libgmodule-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/lib64/libc-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/lib64/librt-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/usr/share/locale/fi/LC_MESSAGES/glib20.mo glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/lib64/libresolv-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/usr/lib64/libffi.so.5.0.10 libffi-3.0.10-1.fc16.x86_64 (Fedora Project) 1323473098
:/lib64/libgio-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/usr/bin/ibus-daemon ibus-1.4.0-11.fc16.x86_64 (Fedora Project) 1323473903
:/lib64/libgobject-2.0.so.0.3000.1 glib2-2.30.1-1.fc16.x86_64 (Fedora Project) 1323473101
:/lib64/libselinux.so.1 libselinux-2.1.6-5.fc16.x86_64 (Fedora Project) 1323615793
:/lib64/libz.so.1.2.5 zlib-1.2.5-5.fc16.x86_64 (Fedora Project) 1323473092
:/lib64/ld-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-21.x86_64 (Fedora Project) 1323615791

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-bvJf1DJ240,guid=43202e050d48ef21e5436e5000000063
:XDG_SESSION_COOKIE=c36b8128a1eeb6f0ea3bc14d00000016-1323856587.719064-683678110
:XDG_RUNTIME_DIR=/run/user/joona
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=kde-plasma
:XDG_VTNR=1
:USERNAME=joona
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-bvJf1DJ240,guid=43202e050d48ef21e5436e5000000063
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-joona-nplLwq/database
:USER=joona
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1260
:SHLVL=1
:GDM_LANG=fi_FI.utf8
:PWD=/home/joona
:GNOME_KEYRING_CONTROL=/tmp/keyring-vsUnCR
:LANG=fi_FI.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=joona
:HOME=/home/joona
:LC_CTYPE=fi_FI.utf8
:GTK_IM_MODULE=ibus
:QT_IM_MODULE=ibus
:XMODIFIERS=@im=ibus

var_log_messages:
:Dec 12 08:34:11 localhost abrt[1986]: Saved core dump of pid 1869 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-12-12-08:34:10-1869 (52637696 bytes)
:Dec 14 11:57:08 localhost abrt[2046]: Saved core dump of pid 1967 (/usr/bin/ibus-daemon) to /var/spool/abrt/ccpp-2011-12-14-11:57:07-1967 (77950976 bytes)
Comment 1 joona.jarvela 2011-12-14 05:07:57 EST
Created attachment 546653 [details]
File: maps
Comment 2 joona.jarvela 2011-12-14 05:07:59 EST
Created attachment 546654 [details]
File: smolt_data
Comment 3 joona.jarvela 2011-12-14 05:08:04 EST
Created attachment 546655 [details]
File: backtrace
Comment 4 fujiwara 2011-12-30 00:32:15 EST
I cannot reproduce your problem.
Do you still reproduce the same error?

(In reply to comment #3)
> Created attachment 546655 [details]
> File: backtrace

Thread 8 (Thread 0x7fa9765ac700 (LWP 2026)):
#0  0x0000003ab78e6a43 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
        resultvar = <optimized out>
        oldtype = 0
        result = <optimized out>
#1  0x0000003ac106aa6d in g_socket_condition_wait (error=0x7fa96c002548, cancellable=0x0, condition=<optimized out>, socket=<optimized out>) at gsocket.c:2833
        poll_fd = {{fd = 19, events = 1, revents = 0}, {fd = 46, events = 0, revents = 0}}
        result = <optimized out>
        num = 1
        timeout = -1
#2  g_socket_condition_wait (socket=<optimized out>, condition=<optimized out>, cancellable=0x0, error=0x7fa96c002548) at gsocket.c:2745
No locals.
#3  0x0000003ac106adc3 in g_socket_receive_with_blocking (socket=0x149ea80 [GSocket], buffer=0x7fa970006400 "AUTH\r\n", size=4096, blocking=1, cancellable=0x0, error=0x7fa96c002548) at gsocket.c:1848
        ret = <optimized out>
        __PRETTY_FUNCTION__ = "g_socket_receive_with_blocking"
#4  0x0000003ac10580a4 in g_input_stream_read (stream=0x7fa9600035e0 [GSocketInputStream], buffer=0x7fa970006400, count=4096, cancellable=0x0, error=0x7fa96c002548) at ginputstream.c:204
        class = 0x7fa968006b50
        res = <optimized out>
        __PRETTY_FUNCTION__ = "g_input_stream_read"
#5  0x0000003ac102e86c in g_buffered_input_stream_real_fill (stream=0x7fa960003c50 [GDataInputStream], count=4096, cancellable=<optimized out>, error=<optimized out>) at gbufferedinputstream.c:672
        priv = 0x7fa960003cc0
        base_stream = <optimized out>
        nread = <optimized out>
        in_buffer = <optimized out>

Note You need to log in before you can comment on or make changes to this bug.