Bug 767537 - openjdk does not include fix from oracle, needed for Windows kerberos interoparability
openjdk does not include fix from oracle, needed for Windows kerberos interop...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Deepak Bhole
David Kutálek
: ZStream
Depends On:
Blocks: 727267 800269
  Show dependency treegraph
 
Reported: 2011-12-14 05:27 EST by Olaf Flebbe
Modified: 2012-06-20 09:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 09:51:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Icedtea Bugzilla 830 None None None Never

  None (edit)
Description Olaf Flebbe 2011-12-14 05:27:16 EST
Description of problem:

Channel Binding for the Kerberos Protocol is implemented incorrectly, causing interopability problems with Windows Server 2008/Internet Explorer.

Version-Release number of selected component (if applicable):

java-1.6.0-openjdk-1.6.0.0-1.41.1.10.4

Oracle has released a patch to this problem, but it is not included in openjdk as provided by Redhat.


How reproducible:

* Setup a AD Domain with W2K8

* Microsoft IE patch KB974455 enabled "Extended Protection" for Integrated Windows Authentication is installed (default now!)

* Add RHEL6 Client to AD Domain 

* Install tomcat and for instance spnego.sf.net and configure a Web Kerberos SSO  (or CAS from jasig or shibboleth from internet2.org )

* Use the Internet Explorer to authenticate a websession 

* You get this java exception.

GSSException: Channel binding mismatch (Mechanism level: ChannelBinding not provided!)

 
More and background information is provided in ticket 
http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=830

Additional info:

Please add the patch which is provided in the icedtea bugzilla to openjdk.
Comment 3 Deepak Bhole 2011-12-19 15:26:22 EST
I have requested a backport upstream:

http://mail.openjdk.java.net/pipermail/jdk6-dev/2011-December/002602.html

Once there, I will request for IcedTea and we can then do RHEL builds.
Comment 9 errata-xmlrpc 2012-06-20 09:51:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0836.html

Note You need to log in before you can comment on or make changes to this bug.