Bug 767559 - glusterd responding to requests from outside the cluster
glusterd responding to requests from outside the cluster
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
shylesh
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-12-14 06:13 EST by shylesh
Modified: 2015-11-03 18:04 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa42
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-12-14 06:13:39 EST
Description of problem:
glusterd responding to requests from outside the cluster

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Always

Steps to Reproduce:
1.create a cluster of 2 machines
2.create some volumes .
3.wipe out /etc/glusterd manually from one of the machine and restart glusterd(now this machine is outside the cluster).
4.issue volume stop (say) from the other machine . 
   
Actual results:
volume stop command fails saying "volume doesn't exists". This is because the peer whose 'store' was wiped out responded to the "volume stop" request without checking if it was coming from a peer part of the cluster.

Expected results:
Volume stop command should fail because of broken cluster. The "wiped out" peer should not respond  (positively/negatively) to the "volume stop" request when coming from a peer not part of its cluster.

Additional info:
Comment 1 Anand Avati 2011-12-19 11:43:07 EST
CHANGE: http://review.gluster.com/787 (glusterd: Fail 'requests' from non-peers.) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 2 shylesh 2012-05-23 10:37:39 EDT
Now glusterd does not respond to peers outside the cluster

Note You need to log in before you can comment on or make changes to this bug.