Bug 76758 - Konsole rename kills clipboard
Konsole rename kills clipboard
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-25 19:03 EDT by Stephen Lawrence Jr.
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Lawrence Jr. 2002-10-25 19:03:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When renaming a konsole shell session, the rename popup automatically highlights
the current name of the session, thus effectively wiping out the contents of the
clipboard and replacing it with the current name of the konsole session.

Version-Release number of selected component (if applicable):
kdebase-3.0.3-13

How reproducible:
Always

Steps to Reproduce:
1.Start konsole
2.highlight some text to place it into the clipboard
3.right click in konsole and "Rename"
4. After re-naming, paste the contents of the clipboard somewhere.
	

Actual Results:  The original name of the konsole session is placed in the
clipboard.

Expected Results:  The original text that was placed in the clipboard before the
rename should be displayed.

Additional info:
Comment 1 Marcin Garski 2005-10-24 15:02:30 EDT
Can you still see this bug on Fedora Core?
Probably it is not a bug but a feature :)

Under X Window System you have two clipboards.
First named PRIMARY where all text that you just select is automaticly copied to
PRIMARY clipboard (overwriting previously selected text), you can paste from
this clipboard by pressing midle mouse button.

Second named CLIPBOARD (Windows-style) when you have to press Ctrl+C to copy
text to this clippboard, and for paste use Ctrl+V

So if you "highlight some text to place it into the clipboard" it's copied to
PRIMARY and when you rename session name by selecting name and pressing
backspace, then selected name will be copied into PRIMARY, then if you "paste
the contents of the clipboard somewhere." by pressing midle mouse button you
will see last selected text (in this case session name), is this is what you get?

But if you "highlight some text to place it into the clipboard" by pressing
Ctrl+C then rename session name and press Ctrl+V and you see "original name of
the konsole session" this is a bug.
Comment 2 Petr Rockai 2006-07-17 14:41:43 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 3 Bill Nottingham 2006-10-18 14:18:09 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.