Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 767611 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freeipmi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 751869
  Show dependency treegraph
 
Reported: 2011-12-14 08:46 EST by Jóhann B. Guðmundsson
Modified: 2012-01-09 03:04 EST (History)
2 users (show)

See Also:
Fixed In Version: freeipmi-1.1.1-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-09 03:04:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file for bmc-watchdog (227 bytes, text/plain)
2011-12-14 08:47 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for ipmidetectd (192 bytes, text/plain)
2011-12-14 08:47 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit for bmc-watchdog.service type forking (237 bytes, text/plain)
2012-01-04 12:22 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit for ipmidetectd type forking (173 bytes, text/plain)
2012-01-04 12:30 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-12-14 08:46:08 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-12-14 08:47:00 EST
Created attachment 546739 [details]
Native systemd service file for bmc-watchdog
Comment 2 Jóhann B. Guðmundsson 2011-12-14 08:47:47 EST
Created attachment 546740 [details]
Native systemd service file for ipmidetectd
Comment 3 Jan Safranek 2012-01-04 08:30:31 EST
Have you tried these unit files? I doubt about 'Type=oneshot', both ipmidetect and bmc-watchdog are forking daemons.
Comment 4 Jóhann B. Guðmundsson 2012-01-04 12:22:05 EST
Created attachment 550731 [details]
Native systemd unit for bmc-watchdog.service type forking
Comment 5 Jóhann B. Guðmundsson 2012-01-04 12:30:25 EST
Created attachment 550737 [details]
Native systemd unit for ipmidetectd type forking
Comment 6 Jóhann B. Guðmundsson 2012-01-04 13:25:56 EST
(In reply to comment #3)
> Have you tried these unit files? I doubt about 'Type=oneshot', both ipmidetect
> and bmc-watchdog are forking daemons.

Hum did not look at their source code to check them. 

I simply dont have time to both convert and run upstream to properly check code and thoroughly test everything we still got ca 300 components to go.

Of those ca 300 we have 100 components which have 100+ units files to them which are stuck in bugzilla and thus aren't receiving any feedback/testing et all from the community and many of the packagers/maintainers of those components seem to be absent.

I have not enacted the non responsive maintainers policy on those maintainers since I dont have time for that either and that process is way to long. 

Those components would need to be removed from the distribution or have new maintainers no later then alpha to make any difference from my pov.

Those non-responsive maintainers are inadvertently delaying the next phase in the systemd migration as in the various clean up phase for those unit's submitted <F16  which by the current migration speed probably winds up to be an F20+ feature.  

+ I cant properly test this since I dont have any IPMI hw. 

Anyway added Type forking version of the unit files but still feel that there is something amiss with the daemons it's like they are exiting cleanly when they should not and aren't properly forking but anyway you are the maintainer and are familiar with the daemons and their code and have the necessary hw to test these so try those units see if they work. 

The sooner you push the unit files into rawhide the more testing and feedback they will receive before GA.
Comment 7 Jan Safranek 2012-01-06 07:44:58 EST
Jóhann, don't get me wrong, I appreciate the work you are doing and I understand your frustration, I was just curious if I miss something or the unit files were just bad.

Regarding testing HW, it's quite interesting problem. We as company have plenty of IPMI enabled HW here, but I don't know any which runs Fedora... I'll try to find some. Anyway, I'll try to provide native unit files for F17.
Comment 8 Jóhann B. Guðmundsson 2012-01-06 08:05:50 EST
(In reply to comment #7)

> Regarding testing HW, it's quite interesting problem. We as company have plenty
> of IPMI enabled HW here, but I don't know any which runs Fedora... I'll try to
> find some. Anyway, I'll try to provide native unit files for F17.

If you can manage to package them that would be great we are that early in the release cycle thus we should be able to let testers/users catch any bugs that may come out of it.

Given the relative simplicity of the unit files fixes to them are usually just one liners...
Comment 9 Jan Safranek 2012-01-06 11:07:16 EST
The way how freeipmi daemons start confuse systemd, I sent a patch upstream: http://lists.gnu.org/archive/html/freeipmi-devel/2012-01/msg00001.html
Comment 10 Jóhann B. Guðmundsson 2012-01-06 11:27:39 EST
Hum...

Did you try adding "Before=bmc-watchdog.service" to the ipmidetectd.service
And ipmidetectd.service to the After line as in "After=network.target ipmidetectd.service" to the bmc-watchdog.service

And still experienced the race condition?
Comment 11 Jan Safranek 2012-01-09 02:55:12 EST
Yes. These two daemons are independent, the race is between two processes of one daemon, not between two daemons. Anyway, upstream accepted my patches:
http://svn.savannah.gnu.org/viewvc?view=rev&root=freeipmi&revision=8299

Note You need to log in before you can comment on or make changes to this bug.