Bug 767699 - ppc64 with matrox video uses fbdev instead of mga
ppc64 with matrox video uses fbdev instead of mga
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-mga (Show other bugs)
16
powerpc Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Blockerppc
  Show dependency treegraph
 
Reported: 2011-12-14 11:55 EST by Will Woods
Modified: 2012-03-14 09:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-14 13:05:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log, showing FBDEV in use (12.86 KB, text/plain)
2011-12-14 11:55 EST, Will Woods
no flags Details
lspci -vv output (4.91 KB, text/plain)
2011-12-14 11:57 EST, Will Woods
no flags Details

  None (edit)
Description Will Woods 2011-12-14 11:55:50 EST
Created attachment 546812 [details]
Xorg.0.log, showing FBDEV in use
Comment 1 Will Woods 2011-12-14 11:57:12 EST
Created attachment 546813 [details]
lspci -vv output
Comment 2 Will Woods 2011-12-14 13:05:29 EST
Wow, my comment got lost when I filed the bug. Awesome.

Anyway, this ppc64 system has a Matrox graphics card:

  0001:02:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G550 AGP
     ^-- possibly interesting non-zero PCI domain

The mga driver claims to support the G550, but Xorg isn't using the mga driver for some reason:

  [   149.468] (**) FBDEV(0): claimed PCI slot 2@1:0:0
  
But as it turns out, the install was done with 'usefbx', which is equivalent to 'xdriver=fbdev', and when you use 'xdriver' anaconda will write /etc/X11/xorg.conf to force that driver into use. Hence fbdev instead of mga.

Note You need to log in before you can comment on or make changes to this bug.