Bug 767712 - subnet_number():inet.c:53: Addr/mask length mismatch
subnet_number():inet.c:53: Addr/mask length mismatch
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 12:36 EST by Eddie Lania
Modified: 2011-12-15 10:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-15 07:07:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2011-12-14 12:36:44 EST
Description of problem:

Starting dhcpd6 always fails with error message subnet_number():inet.c:53: Addr/mask length mismatch.

Dec 14 14:36:43 ls2ka systemd[1]: dhcpd6.service: main process exited, code=exited, status=1
Dec 14 14:36:43 ls2ka systemd[1]: Unit dhcpd6.service entered failed state.

Version-Release number of selected component (if applicable):



How reproducible:
Always


Steps to Reproduce:
1. Install dhcp
2. Configure subnet6 in dhcpd6.conf
3. systemctl start dhcpd6.service
  
Actual results: dhcpd6.service refuses to start with mentioned error in messages log.


Expected results: dhcpd6.service to start


Additional info:

My dhcpd6.conf (which was working before i upgraded to fc16):

subnet6 fdf5:a3af:1d9a::/64 {
        range6 fdf5:a3af:1d9a::101 fdf5:a3af:1d9a::1f4;
        authorative;
        option dhcp6.name-servers fdf5:a3af:1d9a::3;
        option dhcp6.domain-search "elton-intra.net";
        option dhcp-renewal-time 21600;
        option dhcp-rebinding-time 21600;
        option domain-name "elton-intra.net";
        option time-offset 3600;
}
Comment 1 Eddie Lania 2011-12-14 12:42:16 EST
Sorry, I forgot:

Version-Release number of selected component (if applicable):

dhcp-4.2.3-4.P1.fc16.i686
Comment 2 Jiri Popelka 2011-12-15 07:07:53 EST
Well, your dhcpd6.conf works for me (dhcp-4.2.3-4.P1.fc16.x86_64).

I added fdf5:a3af:1d9a::163/64 address to the server's NIC,
added your configuration to dhcpd6.conf and 
the dhcpd6.service started correctly.

If your dhcpd6.conf is bigger than what you've posted then there can be a
problem in some other subnet6 statement.
Comment 3 Eddie Lania 2011-12-15 10:06:20 EST
Okay, I found the problem.
I forgot i had to change the /etc/sysconfig/dhcpd6 to include the -cf option to point to the dhcpd6.conf file.

Now that i changed that it works again.

Sorry for the inconvenience.

Regards,

Eddie.

Note You need to log in before you can comment on or make changes to this bug.