Bug 767761 - syslog-ng 3.2.5-1: file conflicts with RHEL 6.2 rsyslog
Summary: syslog-ng 3.2.5-1: file conflicts with RHEL 6.2 rsyslog
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: syslog-ng
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Jose Pedro Oliveira
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 782867 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-14 20:24 UTC by Jose Pedro Oliveira
Modified: 2015-07-21 13:20 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-12-31 18:58:50 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1244467 None None None Never

Internal Trackers: 1244467

Description Jose Pedro Oliveira 2011-12-14 20:24:29 UTC
Description of problem:
The logrotate file shipped in the RHEL 6.2 rsyslog package was modified.
This modification caused file conflicts with the EPEL6 syslog-ng package.

Version-Release number of selected component (if applicable):
syslog-ng-3.2.5-1.el6
rsyslog-4.6.2-12.el

How reproducible:
Always

Steps to Reproduce:
1. Upgrade a RHEL 6.1 system with syslog-ng as the default syslog daemon (and with the rsyslog daemon installed but disabled). 

  
Actual results:
Yum message:
----------
...
Transaction Check Error:
  file /etc/logrotate.d/syslog from install of rsyslog-4.6.2-12.el6.x86_64 conflicts with file from package syslog-ng-3.2.5-1.el6.x86_64
...
----------


Additional info:
rsyslog logrotate file changes:
----------
$ diff -u ./rsyslog-4.6.2-3.el6_1.4.src/rsyslog.log  ./rsyslog-4.6.2-12.el6.src/rsyslog.log
--- ./rsyslog-4.6.2-3.el6_1.4.src/rsyslog.log	2009-05-20 11:49:33.000000000 +0100
+++ ./rsyslog-4.6.2-12.el6.src/rsyslog.log	2011-08-02 17:28:08.000000000 +0100
@@ -1,4 +1,9 @@
-/var/log/messages /var/log/secure /var/log/maillog /var/log/spooler /var/log/boot.log /var/log/cron {
+/var/log/cron
+/var/log/maillog
+/var/log/messages
+/var/log/secure
+/var/log/spooler
+{
     sharedscripts
     postrotate
 	/bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || true
----------

Comment 1 Jose Pedro Oliveira 2011-12-14 20:42:38 UTC
rsyslog change that caused the file conflict:

 * Bug 683537 - [RFE] Do not use log rotation for /var/log/boot.log
   https://bugzilla.redhat.com/show_bug.cgi?id=683537

Comment 2 Fedora Update System 2011-12-14 22:39:32 UTC
syslog-ng-3.2.5-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/syslog-ng-3.2.5-2.el6

Comment 3 Fedora Update System 2011-12-16 17:41:00 UTC
Package syslog-ng-3.2.5-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing syslog-ng-3.2.5-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-5246/syslog-ng-3.2.5-2.el6
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-12-31 18:58:50 UTC
syslog-ng-3.2.5-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Jose Pedro Oliveira 2012-01-18 18:20:29 UTC
*** Bug 782867 has been marked as a duplicate of this bug. ***

Comment 6 Christopher Wood 2012-01-18 18:53:59 UTC
Hrmph, I didn't see this bug when I searched. My apologies.

I was installing syslog-ng-3.2.5-2.el6.i686 when I filed that other bug, so it looks like the issue persists.

https://bugzilla.redhat.com/show_bug.cgi?id=782867

Although it looks like a complete fix is having both packages install a separately-named file in /etc/logrotate.d. ($0.02, but I'm not the one doing the work.)

Comment 7 Jose Pedro Oliveira 2012-01-18 19:10:18 UTC
(In reply to comment #6)
> Hrmph, I didn't see this bug when I searched. My apologies.
> 
> I was installing syslog-ng-3.2.5-2.el6.i686 when I filed that other bug, so it
> looks like the issue persists.


As we can only track one version of each major RHEL release, we follow the latest and at this moment the latest RHEL6 version is 6.2.

The current syslog-ng version in EPEL6 can be installed in parallel with the rsyslog shipped in RHEL 6.2 (rsyslog-4.6.2-12).

> https://bugzilla.redhat.com/show_bug.cgi?id=782867
> 
> Although it looks like a complete fix is having both packages install a
> separately-named file in /etc/logrotate.d. ($0.02, but I'm not the one doing
> the work.)

Been there, done that ;)

Unfortunately logrotate aborts its execution if it finds duplicated log filenames in the logrotate scripts (/etc/logrotate.d/*). [1]

/jpo

[1] - This logrotate behavior is known for more than 10 years ...

Comment 8 Jose Pedro Oliveira 2012-01-18 19:29:58 UTC
(In reply to comment #6)

To correct this problem you have 2 solutions:

 1) Just remove the rsyslog package (the far better solution), 

 2) Upgrade simultaneously rsyslog (get the RPM(s) from the CentOS 6.2 
    repositories) and syslog-ng (from the EPEL6 repositories)

/jpo


Note You need to log in before you can comment on or make changes to this bug.