Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 767784 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: edac-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aristeu Rozanski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 751869
  Show dependency treegraph
 
Reported: 2011-12-14 16:14 EST by Jóhann B. Guðmundsson
Modified: 2012-03-14 13:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 13:52:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file for edac.service (230 bytes, text/plain)
2011-12-14 16:14 EST, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-12-14 16:14:14 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-12-14 16:14:57 EST
Created attachment 546898 [details]
Native systemd service file for edac.service
Comment 2 Gwyn Ciesla 2012-02-14 11:42:18 EST
Aristeu, any objection to my making this change?
Comment 3 Aristeu Rozanski 2012-02-14 11:52:45 EST
No objection but I don't have time to work on this right now. how soon you want this in?
Comment 4 Gwyn Ciesla 2012-02-14 11:58:33 EST
Ideally early in the f18 timeframe, but I'm willing to do it, if you like.
Comment 5 Jóhann B. Guðmundsson 2012-02-14 12:04:27 EST
Note that the window is open to at least beta to introduce ( I think Tom went bit further than that last development cycle ) units into the release so preferably build this for F17 and ofcourse rawhide
Comment 6 Jóhann B. Guðmundsson 2012-02-14 12:15:55 EST
I should mention once that window is closed so is the ability to introduce units into the GA distribution as in units cannot be introduce as an updated to GA release without explicit granted permission from FESCO. 

Some maintainers have been bitten by this policy as in legacy sysv initscript is broken due to various reasons in F15 and users file bugs left and right but native systemd unit works perfectly in F16 and the maintainer cant really fixed it in F15 since he cant introduce the native systemd unit into that release. 

Note that this policy was NOT set by the systemd crew and generally is disliked amongst them.
Comment 7 Gwyn Ciesla 2012-03-14 12:25:45 EDT
So I can go ahead?
Comment 8 Aristeu Rozanski 2012-03-14 13:29:22 EDT
Yep, please. I started reading about how it works, but ended up being pulled
for something else.
Comment 9 Gwyn Ciesla 2012-03-14 13:52:31 EDT
Done, thanks all!

Note You need to log in before you can comment on or make changes to this bug.