Bug 76789 - Using USB MS Intellimouse Explorer locks system after KDE loads
Using USB MS Intellimouse Explorer locks system after KDE loads
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-26 15:14 EDT by Terrance A. Crow
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terrance A. Crow 2002-10-26 15:14:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
After installing Red Hat Linux 8.0 with all options, logging in as any user, 
issuing startx, waiting for the load the complete, and attempting to use the 
mouse results in a hard lockup of the system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load Alienware system with all options for Linux.
2. Log in as any user.
3. Issue the command startx.
4. Wait for load to complete.
5. Attempt to use the MS Intellimouse Explorer.
6. Attempt CTRL-ALT-Backspace and confirm that system is completely locked.
	

Actual Results:  Needed to power down the unit. This involved either holding 
the power switch down for 7 seconds or using the actual power switch on the 
back of the unit.

Expected Results:  I expected to be able to use the mouse in KDE.

Additional info:

I said the problem with with KDE, but I'm not convinced of that. The problem 
persisted in Gnome. On my system, the problem even happened if I tried to 
install Mandrake 9.0. The fix was to connect the mouse not to the USB port but 
to the PS2 port. However, this results in much less mouse precision and 
responsiveness, especially in games. The system is using an ASUS A7N266-C DDR 
mobo and has 768Mb of 2100 DDR RAM, a Seagate 80Gb Barracuda drive a hda, a 
Western Digital 80Gb drive as hdb, a Soundblast Audigy w/1394 soundcard, a 
Lite-On 16x48xDVD ROM drive, a Lite-On 48/12/58 CD-RW, an Nvidia Ti4600 
graphics adapter, and an AMD 2200+ processor. I've installed Linux on hdb and 
have installed Microsoft Windows XP Professional on hda. It's working fine. 

I should also note that I ran Red Hat 7.3 without problems on the same 
hardware while the mouse was connected to the USB port. Something with the new 
version of Red Hat 8.0 and Mandrake 9.0 is at the root of the problem.
Comment 1 Ngo Than 2002-12-16 17:09:53 EST
Hmm, it's not KDE bug. it's a bug in kernel
Comment 2 Larry Low 2003-02-11 18:42:25 EST
This sounds like the same problem I am recieving.  I am using an Asus A7N266-E 
motherboard.  Using any of the kernels in 8.0 and rawhide this problem occurs 
except for the BOOT kernels.  Plugging any USB device in while in a non-BOOT 
kernel causes an immediate lock-up of the system.

I will be happy to provide further information as needed.
Comment 3 Bugzilla owner 2004-09-30 11:40:07 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.