This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 768292 - mercurial 1.4 too old for opening most repositories
mercurial 1.4 too old for opening most repositories
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mercurial (Show other bugs)
6.1
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Ondrej Oprala
qe-baseos-daemons
: Rebase
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2011-12-16 04:10 EST by Boris Folgmann
Modified: 2016-01-31 21:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Boris Folgmann 2011-12-16 04:10:55 EST
Description of problem:
Shouldn't be the latest RHEL 6.x somewhere at least in sighting distance of bleeding edge?? Every second day I stumble across RPMs which are too old to do their job. Migrating several systems from RHEL 4 and 5 I had the hope that the base distribution is current enough to avoid the use of 3rd party repos and manual rebuilds. Right now I'm disappointed.

mercurial 1.4 is too old for opening most repositories. Note that upstream 2.0 is current.

Version-Release number of selected component (if applicable):
mercurial 1.4

How reproducible:
always

Steps to Reproduce:
1. try to access a repo that was created with a later version of mercurial. In this special case 1.7 or later
  
Actual results:
abort: requirement 'dotencode' not supported!

Expected results:
successfully using the repo

Additional info:
http://mercurial.selenic.com/wiki/RequiresFile
Comment 3 Suzanne Yeghiayan 2012-02-14 18:24:48 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 6 Andrius Benokraitis 2013-10-06 21:39:30 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6, and will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.