Bug 768381 - no Fedora repos in kickstart
Summary: no Fedora repos in kickstart
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: lab controller
Version: 0.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 0.12
Assignee: Amit Saha
QA Contact: Dan Callaghan
URL:
Whiteboard: DistroManagement
Keywords:
: 955693 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-16 14:03 UTC by Jan Stancek
Modified: 2015-07-26 22:14 UTC (History)
11 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-11 04:56:50 UTC


Attachments (Terms of Use)

Description Jan Stancek 2011-12-16 14:03:46 UTC
Description of problem:
Currently when Fedora16 is installed in Beaker, there are no repos in kickstart, so only limited set of packages from distro location is available.

Problem: Task dependencies are not installed.
For example:
03:24:36,338 DEBUG anaconda: no package matching elfutils-libelf-devel
03:24:36,340 DEBUG anaconda: no package matching ntp
03:24:36,424 DEBUG anaconda: no package matching asciidoc
03:24:36,425 DEBUG anaconda: no package matching unifdef
03:24:36,467 DEBUG anaconda: no package matching expect
03:24:36,804 DEBUG anaconda: no package matching xmlto

It looks like Fedora16 actually falls back to upstream repos, because after installation, I'm able to install all these packages.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. install Fedora16, include task which needs for example 'expect' (buildcheck-next or scrashme/multiple)
2. check anaconda.log - 'expect' failed to install


Actual results:
Some task dependencies fail to install

Expected results:
If package is available in Fedora, then task should be able to install it as dependency.

Additional info:

Comment 2 Bill Peck 2011-12-16 17:58:24 UTC
Hi Jan,

Additional repos have always been a problem.  Its very difficult to get the info from rel-eng.  I've asked rel-eng to include the location of additional repos in the .treeinfo file, but until they do that you can do one of two things:

1) yum install the Requires: entries from the test itself.

2) add pkginstall task with arguments to install those packages.



Also - when we move to the updated/new harness we won't be installing any of the Requires: listed in tests during provisioning.  That will be done by the harness.

Comment 3 Nick Coghlan 2012-10-17 04:36:30 UTC
Bulk reassignment of issues as Bill has moved to another team.

Comment 4 Dan Callaghan 2012-10-25 04:44:56 UTC
The problem is that in most labs the Fedora directory tree (which only has a subset of packages) gets imported instead of the Everything directory tree. As it stands we can't import Everything since there is no .composeinfo for it, only for Fedora.

.treeinfo is present for Everything, however. We could add some extra hacks to beaker-import to make it check for Everything and import that instead of Fedora if possible.

Comment 5 Dan Callaghan 2013-01-10 04:01:25 UTC
The workaround needed for this (yum install'ing dependencies in the task) is making a lot of work and mess in everyone's code, so I think we should address this. Even if we just add a hack in beaker-import to make Everything an additional repo for Fedora distros.

Comment 6 Amit Saha 2013-02-21 11:51:48 UTC
Another workaround is to add the Everything repo as an additional repo in the Job XML file:

<repo name="Fedora-everything" url=everything-repo.url/>

This is possible only after this fix is released, however: https://bugzilla.redhat.com/show_bug.cgi?id=912234

Comment 9 Amit Saha 2013-03-05 06:38:35 UTC
On Gerrit: http://gerrit.beaker-project.org/#/c/1782/

Comment 10 Amit Saha 2013-03-13 04:10:40 UTC
(In reply to comment #4)
> The problem is that in most labs the Fedora directory tree (which only has a
> subset of packages) gets imported instead of the Everything directory tree.
> As it stands we can't import Everything since there is no .composeinfo for
> it, only for Fedora.
> 
> .treeinfo is present for Everything, however. We could add some extra hacks
> to beaker-import to make it check for Everything and import that instead of
> Fedora if possible.

I learnt from dgilmore of Fedora rel-eng that that .treeinfo is not supposed to be present for the Everything/ at all. In fact, the master Fedora mirror doesn't have one for F-17. It is present for F-18, which is actually a mistake.

Anyway, the WIP patch I have up in Gerrit doesn't depend on this, so it doesn't change anything for our purpose.

Comment 13 Dan Callaghan 2013-04-11 04:56:50 UTC
Beaker 0.12 has been released.

Comment 14 Raymond Mancy 2013-04-23 22:09:53 UTC
*** Bug 955693 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.