Bug 768406 - The "monitor_link" ip attribute default is backwards
The "monitor_link" ip attribute default is backwards
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci (Show other bugs)
6.2
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Ryan McCabe
Cluster QE
: Rebase
: 773393 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 10:16 EST by Ryan McCabe
Modified: 2012-07-27 15:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: luci-0.26.0-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Cause: The default value of the "monitor_link" attribute of the IP resource agent was displayed backwards. When not specified explicitly, its value was displayed as enabled when it was actually disabled, and vice versa. When making changes to the value of "monitor_link" via luci, the incorrect value was stored. Consequence: Users were shown incorrect information about its current state and were not able to modify its value. Fix: Fixes were made to display its value properly and to write its value properly when users changed it. Result: Users can now view and modify the value of the monitor_link attribute of the IP resource agent.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan McCabe 2011-12-16 10:16:27 EST
The "monitor_link" attribute for the IP resource should default to on, not off. When the box is unchecked, monitor_link="0" should be written.
Comment 1 Ryan McCabe 2011-12-16 10:17:02 EST
Fixed in upstream git commit 96c7e41ec2bfcec3f12efcd0aaed1c299bf32f28
Comment 3 Lon Hohberger 2012-01-30 13:33:35 EST
luci-0.26.0-1.el6.x86_64

* I added a service with an IP and unchecked 'Monitor Link'
  Resulting cluster.conf line:
    <ip address="172.33.33.1" monitor_link="0" sleeptime="10"/>
  PASS

* I checked different pages, then back to edit the service, and 'Monitor Link' was still unchecked.
  PASS

* I edited the service and checked the monitor_link box.
  Resulting cluster.conf line:
    <ip address="172.33.33.1" sleeptime="10"/>
  PASS

* I checked different pages again, then back to edit the service, and 'Monitor Link' was still checked.
  PASS
Comment 6 Ryan McCabe 2012-04-11 23:58:31 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: The default value of the "monitor_link" attribute of the IP resource agent was displayed backwards. When not specified explicitly, its value was displayed as enbabled when it was actually disabled, and vice versa. When making changes to the value of "monitor_link" via luci, the incorrect value was stored.

Consequence: Users were shown incorrect information about its current state and were not able to modify its value.

Change: Fixes were made to display its value properly and to write its value properly when users changed it.

Result: Users can now view and modify the value of the monitor_link attribute of the IP resource agent.
Comment 7 Ryan McCabe 2012-04-12 00:23:51 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -2,6 +2,6 @@
 
 Consequence: Users were shown incorrect information about its current state and were not able to modify its value.
 
-Change: Fixes were made to display its value properly and to write its value properly when users changed it.
+Fix: Fixes were made to display its value properly and to write its value properly when users changed it.
 
 Result: Users can now view and modify the value of the monitor_link attribute of the IP resource agent.
Comment 8 Jan Pokorný 2012-04-12 10:05:23 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
-Cause: The default value of the "monitor_link" attribute of the IP resource agent was displayed backwards. When not specified explicitly, its value was displayed as enbabled when it was actually disabled, and vice versa. When making changes to the value of "monitor_link" via luci, the incorrect value was stored.
+Cause: The default value of the "monitor_link" attribute of the IP resource agent was displayed backwards. When not specified explicitly, its value was displayed as enabled when it was actually disabled, and vice versa. When making changes to the value of "monitor_link" via luci, the incorrect value was stored.
 
 Consequence: Users were shown incorrect information about its current state and were not able to modify its value.
Comment 10 errata-xmlrpc 2012-06-20 08:18:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0766.html
Comment 11 Ryan McCabe 2012-07-27 15:37:38 EDT
*** Bug 773393 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.