Bug 76842 - No Latin American support!
No Latin American support!
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhpl (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-27 18:22 EST by Francisco
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-31 21:53:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francisco 2002-10-27 18:22:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
From about 2 years, no one but Spain uses spanish keyboards. We all now use Latin American keyboards (they are not the same)

I don't believe no one has reported this, since i know lots of latin people that use redhat.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install
2.
3.
	

Actual Results:  No la support

Expected Results:  la support, it's easy to do

Additional info:
Comment 1 Brent Fox 2002-10-31 09:37:11 EST
What is the correct keymap to use for X Windows and the console?  If you can
tell me this, I'll update the keyboard list for this keyboard.
Comment 2 Francisco 2002-10-31 21:34:02 EST
Redhat ships with the proper XFree keylayout. You just can't select it in the 
installer or in the X configuration tools. It's called "la" instead of "es"

About the console, it is called /usr/share/keymaps/i386/querty/la-latin1.map.gz 
in another distro
Comment 3 Francisco 2002-10-31 21:42:32 EST
The problem is the kbd package. It does not compile la support, therefore it's 
not selectable even manually. 

But XFree is easy to fix because the driver is already there.
Comment 4 Francisco 2002-10-31 21:52:57 EST
Sorry 'bout that. la-latin1.map.gz is in redhat 8 too.
So fixing the installer should be pretty easy. As i said, "es" is deprecated 
outside spain. I am curious of why this wasn't reported before.
Comment 5 Brent Fox 2002-11-15 14:51:01 EST
Ok, I've added the correct line to keyboard_models.py in rhpl, which the list of
keyboard models actually comes from.  I've tested it out and it seems to work
for me.  rhpl-0.63-1 should contain the update.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.