Bug 768601 - systemctl should default to --no-pager
Summary: systemctl should default to --no-pager
Keywords:
Status: CLOSED DUPLICATE of bug 713567
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 16
Hardware: i686
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-17 11:07 UTC by Trevor Cordes
Modified: 2011-12-19 06:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-19 06:27:46 UTC
Type: ---


Attachments (Terms of Use)

Description Trevor Cordes 2011-12-17 11:07:38 UTC
Description of problem:
systemctl --all automatically runs output through a pager!  This is anathema to the U*IX way.  We aren't running Windows here.  We all know how to pipe to |less if we want a pager.  What other sysadmin program goes through a pager by default?

Yes, we can specify --no-pager each time (or make an alias) but we shouldn't have to.  The default should be to not use a pager and a new option should be made called --pager which would let people still have this awful behaviour on request.

Version-Release number of selected component (if applicable):
systemd-37-3.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. systemctl --all
  
Actual results:
pipes into your PAGER

Expected results:
don't pipe into pager, let us decide how to

Additional info:
Yes, a political decision, but one that most u*ix-heads will agree on.

Comment 1 Michal Schmidt 2011-12-19 06:27:46 UTC

*** This bug has been marked as a duplicate of bug 713567 ***


Note You need to log in before you can comment on or make changes to this bug.