Bug 768628 - fedora-readonly service erroneous failure
Summary: fedora-readonly service erroneous failure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-17 12:56 UTC by Ian Dall
Modified: 2014-03-17 03:29 UTC (History)
6 users (show)

Fixed In Version: initscripts-9.34.2-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-15 02:23:13 UTC
Type: ---


Attachments (Terms of Use)

Description Ian Dall 2011-12-17 12:56:01 UTC
Description of problem:

When using readonly root with selinux disabled, the fedora-readonly service always reports as failed.

Version-Release number of selected component (if applicable):

initscripts-9.34-2.fc16

How reproducible:

Always

Steps to Reproduce:
1. Configure a system with readonly-root (/etc/sysconfig/readonly-root)
2. Boot with selinux=0
3. systemctl --failed
  
Actual results:
fedora-readonly.service has failed


Expected results:
fedora-readonly.service is not listed

Additional info:

The issue is the helper script /lib/systemd/fedora-readonly exists with the wrong exit status.

[ -n "$SELINUX_STATE" ] && [ -e "$path" ] && restorecon -R "$path"

is not quite the same as

if [ -n "$SELINUX_STATE" ] && [ -e "$path" ]; then
    restorecon -R "$path"
fi

The difference being the status.

If the fedora-readonly.service fails would that effect prevent other services which Require fedora-readonly from running?

Comment 2 Fedora Update System 2012-03-09 16:56:48 UTC
initscripts-9.35-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.35-1.fc17

Comment 3 Fedora Update System 2012-03-09 17:57:44 UTC
Package initscripts-9.35-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.35-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3459/initscripts-9.35-1.fc17
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-03-09 18:25:45 UTC
initscripts-9.34.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.1-1.fc16

Comment 5 Fedora Update System 2012-03-12 18:22:32 UTC
initscripts-9.34.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.2-1.fc16

Comment 6 Fedora Update System 2012-03-15 02:23:13 UTC
initscripts-9.34.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.