This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 76863 - Bug in terminfo el1 - ESC [ 1 K sequence.
Bug in terminfo el1 - ESC [ 1 K sequence.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-28 07:19 EST by Sam Varshavchik
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 17:18:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2002-10-28 07:19:55 EST
Description of Problem:

Reproducible display corruption in terminfo application as a result of
gnome-terminal responding to ESC [ 1 K (terminfo el1) by clearing from the
beginning of the line up to but not including the current cursor position.  The
terminfo el1 sequence should clear from the beginning of the line up to and
including the current cursor position.


Version-Release number of selected component (if applicable):

2.0.1-5

How Reproducible:

Always

Steps to Reproduce:

$ echo -e 'aaaabc\b\E[1K'

Actual Results:

     c

Expected Results:

blank line

Additional Information:
	
Date: Sun, 27 Oct 2002 19:15:52 -0500 (EST)
From: Thomas E. Dickey <dickey@herndon4.his.com>
To: Sam Varshavchik <mrsam@courier-mta.com>
Cc: bug-ncurses@gnu.org
Subject: Re: terminfo el1 sequence semantics.

On Sun, 27 Oct 2002, Sam Varshavchik wrote:

> I'm trying to track down the reason for some occasional screen garbage from
> an application that uses ncurses 5.2 and runs under gnome terminal 2.0.1
>
> The garbage is reproducible. What I've been able to determine is this:
>
> * gnome-terminal uses TERM=xterm

(rofl ;-)

> * the culprit is the following terminfo sequence:
>
>   clr_bol                       el1        cb        Clear to beginning
>                                                      of line
>
> * terminfo specifies '\E[1K' for 'el1'.
>
> * If I set el1 to \s\b\E[1K for xterm, the corruption I'm observing goes
>  away.
>
> Based on that, it appears to me that:
>
> * ncurses expects el1 to clear from the beginning of the line up to, and
>  including the current cursor column.

which happens to be consistent with vt100, etc.  (double-checked just now
by referring to my vt300 manual).

> * gnome terminal responds to \E[1K by clearing from the beginning of the
>  line up to, but not including, the current cursor column.  For example:
>
> $ echo -e 'aaaabc\b\E[1K'
>     c
>
> So, who's right?

It looks like a bug in gnome-terminal
Comment 1 Nalin Dahyabhai 2003-01-09 17:18:24 EST
Fixed in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.