Bug 768775 - latest microcode causes 7zip to panic system
latest microcode causes 7zip to panic system
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: microcode_ctl (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anton Arapov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-18 14:20 EST by Randy
Modified: 2014-06-18 04:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-30 15:26:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy 2011-12-18 14:20:53 EST
Description of problem:

One of these updates causes my system to kernel panic when using 7zip to compress a large directory > 1.5 GB

Version-Release number of selected component (if applicable):

---> Package microcode_ctl.x86_64 1:1.17-18.fc16 will be updated
---> Package microcode_ctl.x86_64 1:1.17-20.fc16 will be an update

How reproducible:

Every time

Steps to Reproduce:

7za u -ppasswordtest -t7z -mx9 -ms=off -xr!*.bmp -xr!*.mp3 -xr!*.JPG -xr!*.jpg -xr!*.wmv -xr!*.avi -xr!*.AVI -xr!*.iso "$DEST/$FILE_NAME".7z "$SRC" > "$DEST/$FILE_NAME".txt 2> "$DEST/$FILE_NAME".err

  
Actual results:

kernel panic

Expected results:

compressed file

Additional info:
Comment 1 Randy 2011-12-18 14:40:08 EST
[rschuster@ajax ~]$ cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.64
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 1
cpu cores	: 4
apicid		: 2
initial apicid	: 2
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.72
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 2
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 2
cpu cores	: 4
apicid		: 4
initial apicid	: 4
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.71
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 3
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 6
initial apicid	: 6
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.71
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 4
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 0
cpu cores	: 4
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.73
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 5
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 1
cpu cores	: 4
apicid		: 3
initial apicid	: 3
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.72
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 6
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 2
cpu cores	: 4
apicid		: 5
initial apicid	: 5
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.71
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6783.72
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

[rschuster@ajax ~]$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:01.1 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.2 PCI bridge: Intel Corporation 82801 PCI Bridge (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation Z68 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for mainboards (rev a3)
02:00.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for mainboards (rev a3)
02:02.0 PCI bridge: nVidia Corporation NF200 PCIe 2.0 switch for mainboards (rev a3)
03:00.0 VGA compatible controller: nVidia Corporation Device 1201 (rev a1)
03:00.1 Audio device: nVidia Corporation Device 0e0c (rev a1)
05:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
08:00.0 PCI bridge: Integrated Technology Express, Inc. Device 8892 (rev 10)
09:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
0a:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
0b:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
0c:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9128 PCIe SATA 6 Gb/s RAID controller with HyperDuo (rev 11)
0d:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9128 PCIe SATA 6 Gb/s RAID controller with HyperDuo (rev 11)
Comment 2 Anton Arapov 2011-12-22 06:44:16 EST
Randy, could you attach the panic message too please. And have you had a chance to ensure the microcode update is indeed caused the panic, did you try to revert update and try to reproduce the panic?
Comment 3 Randy 2011-12-22 11:04:56 EST
It's crashing with microcode_ctl-1.17-18.fc16.x86_64 installed. 

When the system crashes my screen is blank and the system is not on the network. 

Also there doesn't appear to be anything in /var/log/messages

I think I can crash the system at will if you give me more specific instructions on what information you need.
Comment 4 Randy 2011-12-24 10:22:54 EST
Changed job to use xz instead of 7zip and system is still crashing. 

Basically I have a root cron job that backs up home directory files nightly but it doesn't complete anymore. 

If I run it manually from a root bash session it usually does complete but never from cron now for some reason.
Comment 5 Randy 2011-12-29 11:42:25 EST
I think the problem is related to this error.

The system has an encrypted RAID0 array which is getting backed up to a non RAID encrypted files system

 WARNING:  Kernel Errors Present
             res 51/24:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error) ...:  1 Time(s)
Comment 6 Randy 2011-12-29 12:37:22 EST
This information corresponds to a crash that happened this morning, screen clock was stuck on 3:06 when I approached the system at 6:30


Dec 29 03:06:42 ajax kernel: [46406.397257] ata8.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Dec 29 03:06:42 ajax kernel: [46406.397260] ata8.00: irq_stat 0x40000001
Dec 29 03:06:42 ajax kernel: [46406.397263] sr 7:0:0:0: [sr0] CDB: Test Unit Ready: 00 00 00 00 00 00
Dec 29 03:06:42 ajax kernel: [46406.397270] ata8.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Dec 29 03:06:42 ajax kernel: [46406.397271]          res 51/24:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error)
Dec 29 03:06:42 ajax kernel: [46406.397273] ata8.00: status: { DRDY ERR }
Comment 7 Randy 2011-12-30 08:49:27 EST
Seems to happen if I run my backup script while I have VMware guests running


Dec 30 07:40:52 ajax kernel: [ 2465.004175] ata8.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Dec 30 07:40:52 ajax kernel: [ 2465.004178] ata8.00: irq_stat 0x40000001
Dec 30 07:40:52 ajax kernel: [ 2465.004180] sr 7:0:0:0: [sr0] CDB: Test Unit Ready: 00 00 00 00 00 00
Dec 30 07:40:52 ajax kernel: [ 2465.004188] ata8.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Dec 30 07:40:52 ajax kernel: [ 2465.004189]          res 51/24:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error)
Dec 30 07:40:52 ajax kernel: [ 2465.004191] ata8.00: status: { DRDY ERR }
Dec 30 07:41:22 ajax kernel: [ 2494.916370] ata8.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Dec 30 07:41:22 ajax kernel: [ 2494.916372] ata8.00: irq_stat 0x40000001
Dec 30 07:41:22 ajax kernel: [ 2494.916374] sr 7:0:0:0: [sr0] CDB: Test Unit Ready: 00 00 00 00 00 00
Dec 30 07:41:22 ajax kernel: [ 2494.916380] ata8.00: cmd a0/00:00:00:00:00/00:00:00:00:00/a0 tag 0
Dec 30 07:41:22 ajax kernel: [ 2494.916380]          res 51/24:03:00:00:00/00:00:00:00:00/a0 Emask 0x1 (device error)
Dec 30 07:41:22 ajax kernel: [ 2494.916382] ata8.00: status: { DRDY ERR }
Dec 30 07:41:24 ajax kernel: [ 2495.128022] general protection fault: 0000 [#1] SMP 
Dec 30 07:41:24 ajax kernel: [ 2495.128025] CPU 1 
Dec 30 07:41:24 ajax kernel: [ 2495.128026] Modules linked in: hidp lockd vmnet ppdev parport_pc parport fuse vsock vmci vmmon rfcomm bnep nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables sha256_generic nvidia(P) snd_hda_codec_hdmi snd_hda_codec_realtek btusb bluetooth snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd iTCO_wdt iTCO_vendor_support i2c_i801 soundcore i2c_core snd_page_alloc joydev r8169 mii serio_raw rfkill microcode uinput sunrpc xts gf128mul dm_crypt raid0 mxm_wmi usb_storage firewire_ohci firewire_core crc_itu_t wmi [last unloaded: scsi_wait_scan]
Dec 30 07:41:24 ajax kernel: [ 2495.128052] 
Dec 30 07:41:24 ajax kernel: [ 2495.128054] Pid: 4967, comm: vmx-vthread-9 Tainted: P            3.1.6-1.fc16.x86_64 #1 Gigabyte Technology Co., Ltd. Z68X-UD7-B3/Z68X-UD7-B3
Dec 30 07:41:24 ajax kernel: [ 2495.128057] RIP: 0010:[<ffffffff8115f2ca>]  [<ffffffff8115f2ca>] kmem_cache_alloc+0x5a/0x140
Dec 30 07:41:24 ajax kernel: [ 2495.128062] RSP: 0018:ffff880395e9d7b8  EFLAGS: 00010002
Dec 30 07:41:24 ajax kernel: [ 2495.128063] RAX: 0000000000000000 RBX: ffffffff81a7eba0 RCX: 0000000000009123
Dec 30 07:41:24 ajax kernel: [ 2495.128065] RDX: 0000000000009122 RSI: 0000000000015f80 RDI: ffff88040e802800
Dec 30 07:41:24 ajax kernel: [ 2495.128066] RBP: ffff880395e9d808 R08: ffff88041f455f80 R09: ffff8801afafdb00
Dec 30 07:41:24 ajax kernel: [ 2495.128067] R10: 0000000000000000 R11: ffff8801afe63080 R12: ffff88040e802800
Dec 30 07:41:24 ajax kernel: [ 2495.128068] R13: 0e00000000020070 R14: ffffffff813a0a7a R15: 0000000000000020
Dec 30 07:41:24 ajax kernel: [ 2495.128070] FS:  00007fd6e50e2700(0000) GS:ffff88041f440000(0000) knlGS:0000000000000000
Dec 30 07:41:24 ajax kernel: [ 2495.128071] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Dec 30 07:41:24 ajax kernel: [ 2495.128072] CR2: 00007fa350d64000 CR3: 00000002c1737000 CR4: 00000000000406e0
Dec 30 07:41:24 ajax kernel: [ 2495.128073] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Dec 30 07:41:24 ajax kernel: [ 2495.128075] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Dec 30 07:41:24 ajax kernel: [ 2495.128076] Process vmx-vthread-9 (pid: 4967, threadinfo ffff880395e9c000, task ffff88040484ae60)
Dec 30 07:41:24 ajax kernel: [ 2495.128077] Stack:
Dec 30 07:41:24 ajax kernel: [ 2495.128078]  ffff88041f7ece00 ffffffff813a0a63 0000000000000100 0000000000000100
Dec 30 07:41:24 ajax kernel: [ 2495.128081]  ffff88041f456468 ffffffff81a7eba0 ffff8801afafdb00 0000000000000020
Dec 30 07:41:24 ajax kernel: [ 2495.128083]  ffff880400678800 ffff88040075b800 ffff880395e9d838 ffffffff813a0a7a
Dec 30 07:41:24 ajax kernel: [ 2495.128085] Call Trace:
Dec 30 07:41:24 ajax kernel: [ 2495.128090]  [<ffffffff813a0a63>] ? scsi_pool_alloc_command+0x33/0x80
Dec 30 07:41:24 ajax kernel: [ 2495.128092]  [<ffffffff813a0a7a>] scsi_pool_alloc_command+0x4a/0x80
Dec 30 07:41:24 ajax kernel: [ 2495.128094]  [<ffffffff813a0b08>] scsi_host_alloc_command+0x28/0x80
Dec 30 07:41:24 ajax kernel: [ 2495.128096]  [<ffffffff813a0b85>] __scsi_get_command+0x25/0xf0
Dec 30 07:41:24 ajax kernel: [ 2495.128099]  [<ffffffff812a9d5a>] ? kobject_get+0x1a/0x30
Dec 30 07:41:24 ajax kernel: [ 2495.128102]  [<ffffffff813a0d38>] scsi_get_command+0x48/0xc0
Dec 30 07:41:24 ajax kernel: [ 2495.128104]  [<ffffffff813a7cea>] scsi_get_cmd_from_req+0x5a/0x70
Dec 30 07:41:24 ajax kernel: [ 2495.128106]  [<ffffffff813a898b>] scsi_setup_blk_pc_cmnd+0x4b/0x120
Dec 30 07:41:24 ajax kernel: [ 2495.128108]  [<ffffffff813b97b5>] sr_prep_fn+0x1b5/0x530
Dec 30 07:41:24 ajax kernel: [ 2495.128112]  [<ffffffff812909ba>] blk_peek_request+0xba/0x240
Dec 30 07:41:24 ajax kernel: [ 2495.128114]  [<ffffffff813a8f38>] scsi_request_fn+0x58/0x490
Dec 30 07:41:24 ajax kernel: [ 2495.128116]  [<ffffffff8128a59b>] __blk_run_queue+0x1b/0x20
Dec 30 07:41:24 ajax kernel: [ 2495.128118]  [<ffffffff81289a8b>] __elv_add_request+0x11b/0x280
Dec 30 07:41:24 ajax kernel: [ 2495.128120]  [<ffffffff812948bb>] blk_execute_rq_nowait+0x6b/0xe0
Dec 30 07:41:24 ajax kernel: [ 2495.128122]  [<ffffffff812949b3>] blk_execute_rq+0x83/0xf0
Dec 30 07:41:24 ajax kernel: [ 2495.128124]  [<ffffffff8129471f>] ? blk_rq_map_user+0x16f/0x260
Dec 30 07:41:24 ajax kernel: [ 2495.128126]  [<ffffffff812998b2>] sg_io+0x2f2/0x4d0
Dec 30 07:41:24 ajax kernel: [ 2495.128128]  [<ffffffff8129a32d>] scsi_cmd_ioctl+0x49d/0x550
Dec 30 07:41:24 ajax kernel: [ 2495.128132]  [<ffffffff813e5ffe>] cdrom_ioctl+0x4e/0xf40
Dec 30 07:41:24 ajax kernel: [ 2495.128134]  [<ffffffff810a1c70>] ? futex_wake+0x100/0x120
Dec 30 07:41:24 ajax kernel: [ 2495.128136]  [<ffffffff813b8e46>] sr_block_ioctl+0x76/0xf0
Dec 30 07:41:24 ajax kernel: [ 2495.128138]  [<ffffffff81296b90>] blkdev_ioctl+0x2d0/0x720
Dec 30 07:41:24 ajax kernel: [ 2495.128141]  [<ffffffff811a6220>] block_ioctl+0x40/0x50
Dec 30 07:41:24 ajax kernel: [ 2495.128143]  [<ffffffff811842a8>] do_vfs_ioctl+0x98/0x550
Dec 30 07:41:24 ajax kernel: [ 2495.128145]  [<ffffffff8115f38d>] ? kmem_cache_alloc+0x11d/0x140
Dec 30 07:41:24 ajax kernel: [ 2495.128147]  [<ffffffff811847f1>] sys_ioctl+0x91/0xa0
Dec 30 07:41:24 ajax kernel: [ 2495.128150]  [<ffffffff815dccc2>] system_call_fastpath+0x16/0x1b
Dec 30 07:41:24 ajax kernel: [ 2495.128151] Code: 00 4d 8b 04 24 65 4c 03 04 25 f0 d3 00 00 49 8b 50 08 4d 8b 28 4d 85 ed 0f 84 d8 00 00 00 49 63 44 24 20 49 8b 34 24 48 8d 4a 01 <49> 8b 5c 05 00 4c 89 e8 65 48 0f c7 0e 0f 94 c0 84 c0 74 c2 4d 
Dec 30 07:41:24 ajax kernel: [ 2495.128168] RIP  [<ffffffff8115f2ca>] kmem_cache_alloc+0x5a/0x140
Dec 30 07:41:24 ajax kernel: [ 2495.128170]  RSP <ffff880395e9d7b8>
Dec 30 07:41:24 ajax kernel: [ 2495.128172] ---[ end trace 56cc59d168061c4e ]---
Comment 8 Randy 2011-12-30 12:08:11 EST
This only happens when a VMware Player 4.0.1 64 bit guest is running.
Comment 9 Randy 2011-12-30 15:26:59 EST
Think I discovered the source of the problem. 

My main VM guest has access to some files on the host. 

These same files are backed up by the script in question. 

The backup works fine if the VM guest is stopped while the backup operation is performed on the host 

These commands are executed before and after the backup

killall -s SIGSTOP vmware-vmx

killall -s SIGCONT vmware-vmx

Note You need to log in before you can comment on or make changes to this bug.