Bug 768901 - du command throws "Stale NFS file handle" messages
du command throws "Stale NFS file handle" messages
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2011-12-19 06:22 EST by shylesh
Modified: 2013-12-18 19:07 EST (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa42
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-12-19 06:22:28 EST
Description of problem:
du on nfs mount shows stale NFS file handle messages

Version-Release number of selected component (if applicable):
Mainline

How reproducible:
Often

Steps to Reproduce:
1.Create a distribute volume
2.mount the volume on same machine
3.add a brick to the volume while it's still mounted
4. Initiate rebalance
5. after rebalance is completed execute du command on the mount point
  
Actual results:
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18/19/20/20': Stale NFS file handle
3240    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18/19/20
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18/19/19': Stale NFS file handle
3280    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18/19
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18/18': Stale NFS file handle
3320    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/17': Stale NFS file handle
3360    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/16': Stale NFS file handle
3400    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16
3440    ./1/2/3/4/5/6/7/8/9/10/11/12/13/14/15
du: cannot access `./1/2/3/4/5/6/7/8/9/10/11/12/13/14/14': Stale NFS file handle


Expected results:


Additional info:
LOG messages
===============

[2011-12-19 05:47:41.735341] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:41.804527] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:41.870930] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:41.937053] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.004871] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.071607] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.138307] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.205050] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.271404] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.339403] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.405818] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
[2011-12-19 05:47:42.470162] E [nfs3.c:735:nfs3_getattr_resume] 0-nfs-nfsv3: Unable to resolve FH: distro : 00000000-0000-0000-0000-000000000000
Comment 1 Amar Tumballi 2011-12-20 00:29:32 EST
This issue seems to be NFS's File Handle resolution for depth more than 16.. Should be fixed after the GFID based patches go-in.
Comment 2 Amar Tumballi 2012-01-25 00:37:10 EST
With patch http://review.gluster.com/2645 this should be fixed.
Comment 3 shylesh 2012-05-20 06:02:28 EDT
Verified on 3.3.0qa42, no such message appears

Note You need to log in before you can comment on or make changes to this bug.