Bug 76897 - Problems with Norwegian keyboard
Problems with Norwegian keyboard
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kbd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-28 17:50 EST by Bjorn Karlsen
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-14 12:34:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bjorn Karlsen 2002-10-28 17:50:15 EST
Description of Problem:

HW: Abit AT7 motherboard (no PS/2 connectors) and BTC 7932M USB keyboard 
with Norwegian layout.
http://www.abit.com.tw/abitweb/webjsp/english/pt_main_back.jsp?pPRODUCT_TYPE=MotherBoard&pMODEL_NAME=AT7
http://www.btc.com.tw/btc2001_e/products_general_hubless.html

Problem 1:
No Norwegian letters (ae, oslash and aring) in console (before startx).

When keyboard "no" is selected, the keys with Norwegian letters results in 
{|}.
When keyboard "no-latin1" is selecetd, nothing appears on screen when 
hitting the Norwegian keys. (If I backspace the "invisible" characters, I 
end up erasing my prompt).

When the graphical interface is started (startx), the keys works as expected.


Problem 2:
'0' (zero) is displayed when the <Alt Gr> key is hit in console when NumLock 
is on (no graphical interface started).
If I want to enter '@', which is entered as <Alt Gr>+<2>, the result is '0@'.
If I want to enter '@@@@@', the result is '0@@@@@' (entered as <Alt 
Gr>+<2>+<2>+<2>+<2>+<2>).

When the graphical interface is started, the <Alt Gr> key sometimes acts 
strange when hit for the first time.
Usually a single '"' (double quote) is displayed, but sometimes a lot of 
'b's are displayed (I have to stop it by hitting <Esc>). I have not hit the 
<b> key, and no keys are stuck.
Afterwards, the <Alt Gr> key works as expected in the graphical interface.

Problem 1 and 2 appears regardless of which shell I'm using (bash/tcsh).

RH 8.0 is installed from scratch from the CD's (no upgrade).
Comment 1 Bjorn Karlsen 2002-10-31 03:34:23 EST
This bug is not limited to USB keyboards.

I tested a Compaq Professional Workstation AP550 with a Norwegian Compaq PS/2 keyboard and RH 8.0. The bugs appeared on this PC's console as well.
Comment 2 Frode Tennebø 2002-11-02 18:34:51 EST
I can verify problem 2a), ie. Alt-Gr provides a 0 on key-press (not 
key-release) whenever Num Lock is active. This occurs for a whole range of 
tested keyboard maps (us, uk, dk, dk-latin1, no, no-latin, se-latin1, fi).

I don't have any of the other problems which suggest more than one bug.
Comment 3 Bjorn Karlsen 2002-11-04 17:51:47 EST
I've done some more testing. Same HW as in my original problem description.

Since my USB-only HW works in RH 7.3, I tried an upgrade:

I've installed RH 7.3 from scratch using the CDs:
- Norwegian characters are ok in console and KDE.
- <AltGr> works as expected in console and KDE.
- No problems entering '@'.

UPGRADED to RH 8.0 using the CDs:
- In GRUB the keyboard worked.
- When booting RH 8.0, kudzu started and expected a keyboard input.
  The keyboard did not work at all! 
  Had to wait for kudzu to time out 
- The boot continued.
- At login prompt: Neither keyboard nor mouse is working!
Comment 4 Olivier Caudron 2003-01-27 04:45:47 EST
I have the same problem with a "be" keyboard layout on a Fujitsu non-USB 
keyboard on a Duron machine with an Eagletech MB(RH8 too). Worked fine with 
RH73, works fine with Win2000 on the same machine. I have seen a report of this 
bug somewhere on a newsgroup for RH73 though.

It seems the alt-gr key sends a 0x30 scan code after the 0xE0 0x38 on key 
press. It is naturally translated to a "b". I don't know why it translates to 
a "0" on the console, but on X it translates to a double quote because the 
keyboard layout has this mapping for altgr+b. This is also strange in my 
opinion because be keyboards are not supposed to give special chars on 
altgr+alpha. If this was disabled it could be a good temporary workaround.

I would like to stress that benign as it looks it is a very annoying (and even 
crippling) problem because the pipe, at sign, braces and brackets are generated 
that way on this keyboard.
Comment 5 Eido Inoue 2003-07-14 12:34:33 EDT
non-ASCII input into the console won't be supported on UTF-8 based systems (RHL
8+) until the kernel supports it. See the release notes in the next beta for
more info. Of course, input through X will always be supported.

Note You need to log in before you can comment on or make changes to this bug.