Bug 768983 - When consuming a future subscription, the repos --list should be empty.
When consuming a future subscription, the repos --list should be empty.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-rhsm (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Regression
Depends On:
Blocks: 715031 772956 782064
  Show dependency treegraph
 
Reported: 2011-12-19 10:39 EST by John Sefler
Modified: 2013-01-10 05:58 EST (History)
5 users (show)

See Also:
Fixed In Version: python-rhsm-0.98.9-1.el5
Doc Type: Bug Fix
Doc Text:
No Description Needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:44:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-12-19 10:39:15 EST
Description of problem:
Not sure if this bug is client side or server side...
Automated tests found this regression (this has been working for a long time prior to Dec 16, 2011 - not sure what got committed on Fri Dec 16 to cause this)...
When consuming a future subscription, the repos --list should be empty.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-5server ~]# rpm -q subscription-manager
subscription-manager-0.98.8-1.git.12.93a1c2f.el5_7
[root@jsefler-f14-5candlepin candlepin]# git branch
  0.2
  0.3
  0.4
* master
[root@jsefler-f14-5candlepin candlepin]# git show-ref | grep master
b2c4f25b01ca075922dbf6fcab8b6708a6e4a81c refs/heads/master
b2c4f25b01ca075922dbf6fcab8b6708a6e4a81c refs/remotes/origin/master
[root@jsefler-f14-5candlepin candlepin]# 

How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-5server ~]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with id: ba573637-f4a8-4a29-b447-271297c5fe77 

[root@jsefler-onprem-5server ~]# subscription-manager list --avail --ondate 2013-12-01 | grep -A6 -B1 awesomeos-x86_64
ProductName:          	Stackable with Awesome OS for x86_64
ProductId:            	stackable-with-awesomeos-x86_64
PoolId:               	8a90f8573453d962013453da599702d0
Quantity:             	15                       
Multi-Entitlement:    	No                       
Expires:              	12/06/2013               
MachineType:          	physical                 

ProductName:          	Awesome OS for x86_64    
ProductId:            	awesomeos-x86_64         
PoolId:               	8a90f8573453d962013453da5a0102ee
Quantity:             	15                       
Multi-Entitlement:    	Yes                      
Expires:              	12/06/2013               
MachineType:          	physical 

[root@jsefler-onprem-5server ~]# subscription-manager subscribe --pool 8a90f8573453d962013453da5a0102ee
Successfully consumed a subscription from the pool with id 8a90f8573453d962013453da5a0102ee
[root@jsefler-onprem-5server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+

ProductName:          	Awesome OS for x86_64 Bits
ContractNumber:       	23                       
AccountNumber:        	12331131231              
SerialNumber:         	4193357201617098429      
Active:               	True                     
QuantityUsed:         	1                        
Begins:               	12/06/2012               
Expires:              	12/06/2013               

[root@jsefler-onprem-5server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
ProductName:          	Awesome OS for x86_64 Bits
Version:              	3.11                     
Arch:                 	x86_64                   
Status:               	Future Subscription      
Starts:               	12/06/2012               
Expires:              	12/06/2013  

[root@jsefler-onprem-5server ~]# date
Mon Dec 19 10:33:05 EST 2011

^^^  CLEARLY MY ENTITLEMENT BEGINS ON 12/06/2012 WHICH IS IN THE FUTURE

[root@jsefler-onprem-5server ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+
RepoName:             	awesomeos                
RepoId:               	awesomeos                
RepoUrl:              	https://cdn.redhat.com/path/to/awesomeos
Enabled:              	1                        

RepoName:             	awesomeos-x86_64         
RepoId:               	awesomeos-x86_64         
RepoUrl:              	https://cdn.redhat.com/path/to/awesomeos/x86_64
Enabled:              	0                        

RepoName:             	always-enabled-content   
RepoId:               	always-enabled-content   
RepoUrl:              	https://cdn.redhat.com/foo/path/always
Enabled:              	1                        

RepoName:             	never-enabled-content    
RepoId:               	never-enabled-content    
RepoUrl:              	https://cdn.redhat.com/foo/path/never
Enabled:              	0                        

[root@jsefler-onprem-5server ~]# 

^^^ BECAUSE MY ENTITLEMENT IS FOR THE FUTURE, THE repos --list ABOVE SHOULD BE EMPTY.
Comment 2 William Poteat 2011-12-22 08:17:03 EST
In master branch

Commit 37a4ddc94678c2d61580053ea18cd020833fa0e8
Comment 5 John Sefler 2011-12-22 15:22:26 EST
changing component from subscription-manager to python-rhsm
Comment 6 John Sefler 2011-12-22 15:35:12 EST
I re-tested with RHEL5.8 branch build...
[root@jsefler-onprem-5client ~]# rpm -q python-rhsm
python-rhsm-0.98.8-1.git.2.446c775.el5
[root@jsefler-onprem-5client ~]# rpm -q subscription-manager
subscription-manager-0.98.9-1.git.5.4b51014.el5

and I'm blocked by the lack of entitlements as described in comment 4

moving to NEW/FailedQA
Comment 8 James Bowes 2012-01-03 11:36:05 EST
fixed in 5.8 d08f9b22a0dc
and master 35b6c6cad7a9a5
Comment 9 John Sefler 2012-01-03 17:18:14 EST
Again I am failing to verify this bug against version...
[root@jsefler-onprem-5server ~]# rpm -q python-rhsm
python-rhsm-0.98.9-1.git.0.81c61d5.el5
[root@jsefler-onprem-5server ~]# rpm -q subscription-manager
subscription-manager-0.98.10-1.git.0.5d83904.el5

If using the subscription-manager GUI, the future entitlements look good.  They appear in the "My Subscriptions" tab and the Status of "My Installed Software" looks good.

If using the subscription-manager CLI, then we fail to list --consumed on the future entitlements which is a regression...


[root@jsefler-onprem-5server ~]# subscription-manager list --avail --ondate 2013-12-01 | grep -A6 -B1 awesomeos-x86_64
ProductName:          	Stackable with Awesome OS for x86_64
ProductId:            	stackable-with-awesomeos-x86_64
PoolId:               	8a90f85734a546830134a547634802cf
Quantity:             	15                       
Multi-Entitlement:    	No                       
Expires:              	12/22/2013               
MachineType:          	physical                 

ProductName:          	Awesome OS for x86_64    
ProductId:            	awesomeos-x86_64         
PoolId:               	8a90f85734a546830134a54763b902ee
Quantity:             	15                       
Multi-Entitlement:    	Yes                      
Expires:              	12/22/2013               
MachineType:          	physical                 

[root@jsefler-onprem-5server ~]# subscription-manager subscribe --pool 8a90f85734a546830134a547634802cf --pool 8a90f85734a546830134a54763b902ee
Successfully consumed a subscription from the pool with id 8a90f85734a546830134a547634802cf
Successfully consumed a subscription from the pool with id 8a90f85734a546830134a54763b902ee
[root@jsefler-onprem-5server ~]# ls -l /etc/pki/entitlement/total 32
-rw------- 1 root root 1675 Jan  3 17:10 170206864378131982-key.pem
-rw-r--r-- 1 root root 3317 Jan  3 17:10 170206864378131982.pem
-rw------- 1 root root 1675 Jan  3 17:10 2050992371720231602-key.pem
-rw-r--r-- 1 root root 3382 Jan  3 17:10 2050992371720231602.pem
[root@jsefler-onprem-5server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
ProductName:          	Stackable with Awesome OS for x86_64 Bits
Version:              	3.11                     
Arch:                 	x86_64                   
Status:               	Future Subscription      
Starts:               	12/22/2012               
Expires:              	12/22/2013               

ProductName:          	Awesome OS for x86_64 Bits
Version:              	3.11                     
Arch:                 	x86_64                   
Status:               	Future Subscription      
Starts:               	12/22/2012               
Expires:              	12/22/2013               

[root@jsefler-onprem-5server ~]# subscription-manager list --consumed
No Consumed subscription pools to list

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
THAT'S NOT CORRECT. WE REALLY ARE CONSUMING ENTITLEMENTS!
EXPECTING A Consumed Product Subscriptions LIST TO SHOW THE CONSUMED ENTITLEMENTS WITH A Begins DATE IN THE FUTURE.


Moving back to NEW/FailedQA
Comment 10 James Bowes 2012-01-04 14:58:52 EST
should be fixed in master 4acdd2ec and
RHEL5.8 9121472ea2
Comment 11 John Sefler 2012-01-09 14:36:51 EST
Verifying Version...
[root@jsefler-onprem-5server ~]# rpm -q python-rhsm
python-rhsm-0.98.9-1.git.0.81c61d5.el5
[root@jsefler-onprem-5server ~]# rpm -q subscription-manager
subscription-manager-0.98.10-1.git.9.a37c702.el5


[root@jsefler-onprem-5server ~]# subscription-manager register --username testuser1 --password password --org admin
The system has been registered with id: e3acfbd7-dafe-46b7-8348-c7a99b425ed3 

[root@jsefler-onprem-5server ~]# date
Mon Jan  9 14:23:37 EST 2012

[root@jsefler-onprem-5server ~]# subscription-manager list --avail --ondate 2013-12-01 | grep -A6 -B1 awesomeos-x86_64
ProductName:          	Stackable with Awesome OS for x86_64
ProductId:            	stackable-with-awesomeos-x86_64
PoolId:               	8a90f85734bffea40134bfffc17502d0
Quantity:             	15                       
Multi-Entitlement:    	No                       
Expires:              	12/27/2013               
MachineType:          	physical                 

ProductName:          	Awesome OS for x86_64    
ProductId:            	awesomeos-x86_64         
PoolId:               	8a90f85734bffea40134bfffc1eb02ee
Quantity:             	15                       
Multi-Entitlement:    	Yes                      
Expires:              	12/27/2013               
MachineType:          	physical                 

[root@jsefler-onprem-5server ~]# subscription-manager subscribe --pool 8a90f85734bffea40134bfffc1eb02ee
Successfully consumed a subscription from the pool with id 8a90f85734bffea40134bfffc1eb02ee

[root@jsefler-onprem-5server ~]# subscription-manager list --consumed
+-------------------------------------------+
    Consumed Product Subscriptions
+-------------------------------------------+

ProductName:          	Awesome OS for x86_64 Bits
ContractNumber:       	23                       
AccountNumber:        	12331131231              
SerialNumber:         	2288287204143030675      
Active:               	None                     
QuantityUsed:         	1                        
Begins:               	12/27/2012               
Expires:              	12/27/2013               

[root@jsefler-onprem-5server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
ProductName:          	Awesome OS for x86_64 Bits
Version:              	3.11                     
Arch:                 	x86_64                   
Status:               	Future Subscription      
Starts:               	12/27/2012               
Expires:              	12/27/2013               

[root@jsefler-onprem-5server ~]# subscription-manager repos --list
The system is not entitled to use any repositories.

[root@jsefler-onprem-5server ~]# yum repolist
Loaded plugins: katello, product-id, rhnplugin, security, subscription-manager
Updating certificate-based repositories.
This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0



The consumption of a future entitlement is reflected in the list --consumed, list --installed, the gui (screenshot not included), and the future entitled repos are not listed in repos --list nor yum repolist.

Moving to VERIFIED
Comment 14 William Poteat 2012-01-27 09:44:35 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No Description Needed
Comment 15 errata-xmlrpc 2012-02-21 01:44:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0280.html

Note You need to log in before you can comment on or make changes to this bug.