Bug 768986 - desktop file errors
Summary: desktop file errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: unixODBC
Version: 6.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jan Staněk
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 947782 768987
TreeView+ depends on / blocked
 
Reported: 2011-12-19 15:44 UTC by Karel Volný
Modified: 2014-07-10 07:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the desktop file for unixODBC, ODBCConfig.desktop, contained deprecated options and incorrect values. Consequently, the unixODBC application was not appropriately categorized. In this update, the options and values have been fixed and the application categorization works as intended.
Clone Of:
: 768987 (view as bug list)
Environment:
Last Closed: 2014-07-10 07:51:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix for ODBCConfig.desktop (386 bytes, patch)
2011-12-20 17:28 UTC, Honza Horak
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0869 normal SHIPPED_LIVE unixODBC bug fix update 2014-07-10 11:51:24 UTC

Description Karel Volný 2011-12-19 15:44:02 UTC
Description of problem:
The subpackage unicODBC-kde contains the file ODBCConfig.desktop which doesn't follow the guidelines.

Version-Release number of selected component (if applicable):
unixODBC-kde-2.2.14-11.el6

How reproducible:
always

Steps to Reproduce:
1. desktop-file-validate ODBCConfig.desktop
  
Actual results:
ODBCConfig.desktop: error: (will be fatal in the future): value "LinuxODBC.xpm" for key "Icon" in group "Desktop Entry" is an icon name with an extension, but there should be no extension as described in the Icon Theme Specification if the value is not an absolute path
ODBCConfig.desktop: warning: key "Encoding" in group "Desktop Entry" is deprecated
ODBCConfig.desktop: error: (will be fatal in the future): value "X-Red-Hat-Extra;" for key "Categories" in group "Desktop Entry" does not contain a registered main category

Expected results:
(no errors)

Additional info:

Comment 1 Honza Horak 2011-12-20 17:28:18 UTC
Created attachment 548900 [details]
fix for ODBCConfig.desktop

We can use "Settings" for category, other fixes are clear.

Comment 3 Suzanne Yeghiayan 2012-02-14 23:24:59 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Jan Staněk 2014-05-06 14:06:25 UTC
Appliend Honza's patch, desktop-file-validate now shows no errors or warnings.

Comment 8 errata-xmlrpc 2014-07-10 07:51:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0869.html


Note You need to log in before you can comment on or make changes to this bug.