Bug 769017 - Rebase the IceWM package from bluecurve to dmz
Summary: Rebase the IceWM package from bluecurve to dmz
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: icewm
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Laszlo Ersek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-19 16:57 UTC by Laszlo Ersek
Modified: 2012-03-24 19:10 UTC (History)
4 users (show)

Fixed In Version: icewm-1.3.7-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-20 00:20:09 UTC


Attachments (Terms of Use)
update theme dependency (1.35 KB, patch)
2011-12-20 20:32 UTC, Laszlo Ersek
lersek: review? (gilboad)
Details | Diff

Description Laszlo Ersek 2011-12-19 16:57:23 UTC
Description of problem:

IceWM can't currently be installed on RHEL-6, because it depends on "bluecurve-icon-theme", and "bluecurve-icon-theme" conflicts (is obsoleted by) "dmz-cursor-themes". I removed the Requries: line from the IceWM spec file, rebuilt it (*), and it seems to work okay. I guess the SPEC file should specify "dmz-cursor-themes" as new dependency.

(*) Rebuilding IceWM on RHEL-6.2 Workstation is very tedious. There are a bunch of build-deps that are not available either in RHEL-6 or in EPEL-6 -- those build dependencies had to be installed from Fedora SRPMs too. One such package is giflib-devel.

Version-Release number of selected component (if applicable):
1.3.7-1.el6

Thanks.

Comment 1 Laszlo Ersek 2011-12-19 19:10:10 UTC
(In reply to comment #0)

> (*) Rebuilding IceWM on RHEL-6.2 Workstation is very tedious. There are a bunch
> of build-deps that are not available either in RHEL-6 or in EPEL-6 -- those
> build dependencies had to be installed from Fedora SRPMs too. One such package
> is giflib-devel.

Disregard that, PEBKAC.

http://fedoraproject.org/wiki/EPEL#How_can_I_use_these_extra_packages.3F

    NOTE: You need to also enable the 'optional' repository to use EPEL
    packages as they depend on packages in that repository.

giflib-devel is in optional.

Comment 2 Laszlo Ersek 2011-12-20 20:30:10 UTC
Adding more info as I tried to look into it more.

icewm-1.3.7-1.el6 [1] requires, since 1.2.32-5, bluecurve-icon-theme.

The bluecurve-icon-theme SRPM produces two binary (actually, noarch) RPMs, bluecurve-icon-theme and bluecurve-cursor-theme. This is the dependency:

icewm --> bluecurve-icon-theme --> bluecurve-cursor-theme

The bluecurve-*-theme packages were built for RHEL-6 [2], but before they could have made their way into 6.0, they were removed due to bug 559765, obsoleted by dmz-cursor-themes-0.4-4.el6 [3]. dmz-cursor-themes is a very basic package and can't be removed in practice.

So, even if we rebuild the bluecurve-*-theme packages in EPEL-6 [4], they still can't be installed on RHEL-6.

icewm -> bluecurve-icon-theme -> bluecurve-cursor-theme <<>> dmz-cursor-themes

I think this could be resolved by rebasing icewm to dmz-cursor-themes. dmz-cursor-themes only provides cursors and not icons, while the bluecurve packages provide both. Anyway at first I simply removed the "Requires:" line from the SPEC file and rebuilt the RPM locally, and IceWM seems to work well (as said above, the dmz-cursor-themes package is very low-level, so it was installed on my system). That said, I use my own customized copy of the warp3 theme.

[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=275455
[2] https://brewweb.devel.redhat.com/buildinfo?buildID=124860
[3] https://brewweb.devel.redhat.com/buildinfo?buildID=131395
[4] http://koji.fedoraproject.org/koji/buildinfo?buildID=279326

Comment 3 Laszlo Ersek 2011-12-20 20:32:18 UTC
Created attachment 548939 [details]
update theme dependency

dmz-cursor-themes obsoleted bluecurve-cursor-theme (RHBZ#559765). The
latter is a dependency of bluecurve-icon-theme. Rebase EPEL-6 build to
dmz-cursor-themes.

koji build: https://koji.fedoraproject.org/koji/taskinfo?taskID=3596563

Comment 4 Gilboa Davara 2012-02-20 00:12:05 UTC
Hello,

Sorry for the belated reply (I was partially AFK).
I plan to issue a fixed build next week (bluecurve issue).

- Gilboa

Comment 5 Gilboa Davara 2012-02-20 00:20:09 UTC

*** This bug has been marked as a duplicate of bug 768844 ***

Comment 6 Fedora Update System 2012-03-05 06:07:58 UTC
icewm-1.3.7-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/icewm-1.3.7-3.el6

Comment 7 Fedora Update System 2012-03-24 19:10:07 UTC
icewm-1.3.7-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.