Bug 769076 - blueman rpm missing dependency causes fail to start in kde
blueman rpm missing dependency causes fail to start in kde
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
16
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 16:17 EST by Simon Dible
Modified: 2012-05-06 00:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: blueman-1.23-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-05 21:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Dible 2011-12-19 16:17:14 EST
Description of problem:
Blueman-applet fails to start on kde distributions when install through yum due to missing gnome dependency. The missing package is "gnome-icon-theme-legacy", can you please add it to the list. 

when gnome-icon-theme-legacy is installed everything works fine. 


Version-Release number of selected component (if applicable):
F15 and f16 kde spins have this problem.
blueman-1.21-10


How reproducible:
Using a fresh kde install of F15 and F16, yum -y install blueman
then run blueman-applet 

  
Actual results:
The fail message when started from the terminal is 
__load_plugin (/usr/bin/blueman-applet:182)
loading <class 'blueman.plugins.applet.PowerManager.PowerManager'> 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/blueman/plugins/AppletPlugin.py", line 105, in _load
    self.on_load(applet)
  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PowerManager.py", line 37, in on_load
    self.item = create_menuitem(_("<b>Bluetooth Off</b>"), get_icon("gtk-stop", 16))
  File "/usr/lib/python2.7/site-packages/blueman/Functions.py", line 171, in get_icon
    icon = ic.load_icon("gtk-missing-image", size, 0)
GError: Icon 'gtk-missing-image' not present in theme

Expected results:
Applet launches

Additional info:
As stated above fix is to add the additional dependency "gnome-icon-theme-legacy" into the rpm. 
FYI: I believe this has also been seen on Debian systems.
Comment 1 Christoph Wickert 2012-04-27 05:44:02 EDT
This is fixed in 1.23 because another icon was chosen.
Comment 2 Fedora Update System 2012-04-27 06:00:54 EDT
blueman-1.23-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc17
Comment 3 Fedora Update System 2012-04-27 06:01:19 EDT
blueman-1.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/blueman-1.23-1.fc16
Comment 4 Fedora Update System 2012-04-27 11:43:31 EDT
Package blueman-1.23-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blueman-1.23-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6784/blueman-1.23-1.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-05-05 21:29:36 EDT
blueman-1.23-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2012-05-06 00:57:01 EDT
blueman-1.23-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.