Bug 769127 - HP LaserJet 1020 - Printer does not print.
HP LaserJet 1020 - Printer does not print.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
16
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 20:15 EST by Noe Nieto
Modified: 2011-12-21 11:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-21 11:14:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of printing troubleshooter. (145.12 KB, text/plain)
2011-12-19 20:15 EST, Noe Nieto
no flags Details

  None (edit)
Description Noe Nieto 2011-12-19 20:15:39 EST
Created attachment 548726 [details]
Output of printing troubleshooter.

Description of problem:

HP LaserJet 1020 has been detected and a queue has been set. Printing from any application does not result in the actual page printed.


Version-Release number of selected component (if applicable):

hplip 3.11.10

How reproducible:

Every time. Except when I have previously printed on windows. Then it does print. May be an issue with some firmware not uploading correctly.

Steps to Reproduce:

- Install hplip
- Gnome (or the apropiate component) detectes the printer and prompts to
install various packages. 
- At the end of the process the printer queue was installed and reported no errors.

- I sent a print job (a test page) to the printer queue. The job was processed
within some seconds and removed from printer queue.

  
Actual results:

No page was printed


Expected results:

Page should print.

Additional info:

See attachments.
Comment 1 Jiri Popelka 2011-12-20 05:50:47 EST
Seems that you actually use foo2zjs and not hplip.

- remove the foo2zjs package
- make sure you have hplip installed
- remove the printer queue
- create new printer queue
- install proprietary plugin which you printer needs to work with hplip. You can do that with 'hp-plugin'.
- attach another troubleshooter output
Comment 2 Tim Waugh 2011-12-20 06:16:27 EST
The reason foo2zjs is getting used here now is probably because (a) rpmfusion.org is enabled on this system, and (b) rpmfusion.org's foo2zjs package now provides IEEE 1284 Device IDs for printer models it supports.

It would be worth reporting a bug to the foo2zjs packagers by following the instructions here:
  http://rpmfusion.org/ReportingBugs

To try HPLIP as Jiri suggests above, first disable the rpmfusion.org repository (you can re-enable it afterwards).
Comment 3 Noe Nieto 2011-12-21 11:14:53 EST
My steps:

- Delete print queue
- Remove foo2zjs.
- Removed printer queue
- Connect printer. Gnome shell asks me to install foo2zjs again to setup the printer queue.

Restart testing without RPMFusion.

- Delete print queue.
- Disable RPMFusion (Free & Free Updates)
- yum update
- Gnome shells reports that printer is detected and the drivers are installing, but never reports if the operation succeeded or not. foo2zjs is not requested to be installed.
- Confirm queue has been created on system-config-printer.
- Print test page. Job is stuck indefinitely in queue with status: "stopped".
- Purge print queue.
- hp-plugin is already installed, but fails to run because hplip-gui is not installed. Installing.
- Run hp-plugin, installs driver and printer is working.

I'll close this bug and forward this bug bug to RPMFusion.

Note You need to log in before you can comment on or make changes to this bug.