Bug 76917 - Fails to find cd in second cd drive
Fails to find cd in second cd drive
Status: CLOSED DUPLICATE of bug 188750
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-29 08:19 EST by Mark Cooke
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 00:20:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Cooke 2002-10-29 08:19:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Default RH 8.0 install.
IDE CD/DVD as hda (/dev/cdrom)
IDE CDRW as hdc (/dev/cdrom1)

Running package config, putting the CD into cdrom1, package config does not find
the data.

Ejecting the disk and putting the same disk into /dev/cdrom works as expected

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See description

Actual Results:  Package config continued to ask for the disk.

Expected Results:  It should have found the disk on any CD device, or at least
have a configuration option to let you specify the device to check.

(In my case, cdrom1 is x48, cdrom is only x8)

Additional info:
Comment 1 Jeremy Katz 2002-10-31 18:01:47 EST
What is the output of '/usr/sbin/kudzu -p -c CDROM'?
Comment 2 Mark Cooke 2002-10-31 23:44:26 EST
$ kudzu -p -c CDROM
-
class: CDROM
bus: IDE
detached: 0
device: hda
driver: ignore
desc: "LG DVD-ROM DRD-8160B"
-
class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "Lite-on LTR-32123S"
host: 0
id: 0
channel: 0
lun: 0
Comment 3 Jeremy Katz 2002-11-05 13:17:21 EST
Could you attach your /etc/fstab?  Also, if you run from a terminal, do you get
any warnings about an unknown cddev?
Comment 4 Need Real Name 2002-11-10 22:45:54 EST
I have the same problem as mpc@star.sr.bham.ac.uk, but in addition,
rpm-config-packages crashed after it started spinning the disc in cdrom1. If I
start up the program with the disc in cdrom it starts okay.

$ kudzu -p -c CDROM

class: CDROM
bus: IDE
detached: 0
device: hdd
driver: ignore
desc: "_NEC DV-5700A"
-
class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "Btc BCE1610IM"
host: 0
id: 0
channel: 0
lun: 0

$ cat /etc/fstab
LABEL=/                 /                       ext3    defaults               
        1 1
LABEL=/boot             /boot                   ext3    defaults               
        1 2
none                    /dev/pts                devpts  gid=5,mode=620         
        0 0
none                    /proc                   proc    defaults               
        0 0
none                    /dev/shm                tmpfs   defaults               
        0 0
/dev/hda5               swap                    swap    defaults               
        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro  
        0 0
/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro  
        0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu     
        0 0
/dev/hda4               /mnt/jwin               vfat   
uid=501,gid=501,mode=0750        0 0

I tried running redhat-config-packages from gnome-terminal and got no errors.

Hope this helps...
Comment 5 Mark Cooke 2002-11-11 19:21:54 EST
Sorry for the delay - I was out of the country.  fstab below, and I'll check for
errors on a terminal tomorrow when I'm in front of the box and can put a cd in
the right drive.

fstab:

/dev/md2                /                       ext3    defaults        1 1
LABEL=Backups           /backups                ext3    defaults        1 2
/dev/md1                /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hdc1               swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0


Device nodes:

lrwxrwxrwx    1 root     root            8 Oct  4 00:36 /dev/cdrom -> /dev/hdb
lrwxrwxrwx    1 root     root            9 Oct  4 00:36 /dev/cdrom1 -> /dev/scd0

And in case you need it, raidtab:

raiddev             /dev/md2
raid-level                  0
nr-raid-disks               2
chunk-size                  64k
persistent-superblock       1
nr-spare-disks              0
    device          /dev/hde2
    raid-disk     0
    device          /dev/hdg2
    raid-disk     1
raiddev             /dev/md1
raid-level                  1
nr-raid-disks               2
chunk-size                  64k
persistent-superblock       1
nr-spare-disks              0
    device          /dev/hde1
    raid-disk     0
    device          /dev/hdg1
    raid-disk     1
Comment 6 Milan Kerslager 2002-11-13 15:10:38 EST
I my case this program crash when I inserted second CD and click to continue in
installation proces. There was no difference beetween I just put secon CD into
CD-ROM or I mounted it. It only complain about can't read the package. It wrote
on console message about 'hit enter to repeat' but program exited.

The CD was always unmouted after the crash.

Also - I don't know how to solve broken dependencies when this program crash in
the middle of installation process. This should be solved too.
Comment 7 Mark Cooke 2002-11-13 15:24:54 EST
I ran an strace -f on the process while running.

It seems it never attempts to access /dev/cdrom1, so I suppose it is not overly
surprising it doesn't see the CD in that drive.

As wattelli@uchastings.edu reported, there are no warnings or errors from
redhat-config-packages on console when it checks for the CD.
Comment 8 Mark Cooke 2002-11-13 15:47:16 EST
Duh.  Didn't look hard enough in the strace log for cdrom1.

The /dev/cdrom1 access is there, but only ever as:

[pid 25527] lstat64("/dev/cdrom1", {st_mode=S_IFLNK|0777, st_size=9, ...}) = 0
[pid 25527] readlink("/dev/cdrom1", "/dev/scd0", 4096) = 9

then

[pid 25527] mount("/dev/cdrom1", "/mnt/cdrom1", "iso9660", MS_RDONLY, 0) = 0

and finally a:

[pid 25527] write(7, "/dev/cdrom1 /mnt/cdrom1 iso9660 "..., 39) = 39


Doing a similar grep though the log for cdrom gives very suspicious looking
calls to:

[pid 25527] access("/mnt/cdrom/.discinfo", R_OK) = -1 ENOENT (No such file or
d$[pid 25527] access("/mnt/cdrom/.discinfo", F_OK) = -1 ENOENT (No such file or
d$[pid 25527] stat64("/mnt/cdrom", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
[pid 25527] oldumount("/mnt/cdrom")     = -1 EINVAL (Invalid argument)

after the mount of cdrom1, but just before the trace shows the first attempt to
mount /dev/cdrom!

It appears redhat-config-package is getting confused, and trying to access
/mnt/cdrom for /dev/cdrom1, instead of /mnt/cdrom1


Hope the above helps trace the problem.  The trace is availble on request - it's
half a meg even compressed so I didn't want to attach it.
Comment 9 Joseph Shraibman 2002-11-28 18:47:50 EST
config-packages needs to be able to read packages from arbitary locations. I
have the install disk images on my local hdd (and mounted via loopback) but
config-packages would complain "Psyce 8.0 disk 1 needed to install packages" and
there was no way to tell it to look anywhere else.
Comment 10 Jeremy Katz 2003-02-09 21:00:04 EST
Should be better in 1.1.6-1 which will show up in rawhide rsn.
Comment 11 John Thacker 2006-04-22 00:20:57 EDT
RH 8 is unsupported.  Also, s-c-p has been replaced by pirut.  There are issues
with pirut and CD installs; marking as duplicate of that bug.

*** This bug has been marked as a duplicate of 188750 ***

Note You need to log in before you can comment on or make changes to this bug.