Bug 769260 - xbean-3.11.1 is available
xbean-3.11.1 is available
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xbean (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 839997
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 06:51 EST by Upstream Release Monitoring
Modified: 2012-07-16 04:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 04:51:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Convert patch to POM macros (5.66 KB, patch)
2012-07-13 09:30 EDT, Mikolaj Izdebski
no flags Details | Diff
Update to upstream version 3.11.1 (3.08 KB, patch)
2012-07-13 09:31 EDT, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Upstream Release Monitoring 2011-12-20 06:51:47 EST
Latest upstream release: 3.9
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2012-04-18 07:08:23 EDT
Latest upstream release: 3.10
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Upstream Release Monitoring 2012-05-11 07:02:36 EDT
Latest upstream release: 3.11
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 3 Upstream Release Monitoring 2012-06-12 16:27:23 EDT
Latest upstream release: 3.11.1
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 4 Upstream Release Monitoring 2012-06-13 05:44:16 EDT
Latest upstream release: 3.11
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 5 Upstream Release Monitoring 2012-06-16 06:44:13 EDT
Latest upstream release: 3.11.1
Current version in Fedora Rawhide: 3.8
URL: http://repo2.maven.org/maven2/org/apache/xbean/xbean/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 6 Mikolaj Izdebski 2012-07-13 08:14:35 EDT
xbean-bundleutils module fails to build because of a bug in OpenJDK:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7078419

Preferred long-term solution is to patch Eclipse to build Equinox classes in 1.5 format.

Possible short-term workarounds:
 1) build xbean using ECJ instead of OpenJDK
 2) disable xbean-bundleutils module
Comment 7 Mikolaj Izdebski 2012-07-13 09:30:43 EDT
Created attachment 598070 [details]
Convert patch to POM macros
Comment 8 Mikolaj Izdebski 2012-07-13 09:31:35 EDT
Created attachment 598071 [details]
Update to upstream version 3.11.1

Note You need to log in before you can comment on or make changes to this bug.