Bug 769454 - RFE: new version available
Summary: RFE: new version available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: skychart
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattia Verga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-20 21:36 UTC by Mattia Verga
Modified: 2012-01-31 22:02 UTC (History)
2 users (show)

Fixed In Version: skychart-3.4-4.fc16.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-31 22:02:03 UTC
Type: ---


Attachments (Terms of Use)

Description Mattia Verga 2011-12-20 21:36:58 UTC
The last version of skychart available in repositories is 3.2, but the upstream stable version is 3.4.

I made some packages myself, tested locally with mock. I'm not a packager, but I would like to became a co-maintainer. I need a review of this package and a sponsorship, if possible.

You can found the .spec and source rpm at:
http://www.messafuoco.com/fedora/skychart.spec
http://www.messafuoco.com/fedora/skychart-3.4-1.fc16.src.rpm

Thank you

Comment 1 Mattia Verga 2011-12-31 11:00:38 UTC
Any news on this?

I already made some other progress on packaging to fix some rpmlint warning and creating a separate subpackage for wiki documentation (that in previous versions were deleted from sources):
http://www.messafuoco.com/fedora/skychart.spec
http://www.messafuoco.com/fedora/skychart-3.4-2.fc16.src.rpm

Feel free to use as scratch for upgrading the package in repositories, if you want.

Comment 2 Sergio Pascual 2012-01-01 10:40:14 UTC
I hope I can push this forward the next week.

Thanks for your contribution, and happy New Year

Comment 3 Sergio Pascual 2012-01-19 23:08:16 UTC
I'm starting to integrate your changes into my specfile. I have found that the package doesn't compile in F-17... 

I suppose is something related with gcc 4.7. I'm reporting upstream

Comment 4 Mattia Verga 2012-01-20 17:43:44 UTC
Note that the 3.6 version is coming shortly (probably). In this version there will be some changes in the source package as described in this discussion: http://www.ap-i.net/mantis/view.php?id=927

Essentially the author has agreed to integrate the wiki documentation and all catalog data in the source package. Also it will be not necessary to remove prohibited code (*.exe) as it will not installed without explicitly say that with a "make install_nonfree".

I already did some tests on a specfile for this future version and it looks good (but it fails to build against f17 for the same reasons related to gcc 4.7). I have also applied in pkgdb a request to become co-maintainer of the package, if you agree to that I can give some help.

Mattia

Comment 5 Fedora Admin XMLRPC Client 2012-01-22 09:11:53 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 Fedora Update System 2012-01-22 13:29:59 UTC
skychart-3.4-4.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/skychart-3.4-4.fc16.1

Comment 7 Fedora Update System 2012-01-22 22:56:31 UTC
Package skychart-3.4-4.fc16.1:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing skychart-3.4-4.fc16.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0810/skychart-3.4-4.fc16.1
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-01-31 22:02:03 UTC
skychart-3.4-4.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.