Bug 76947 - Upgrade won't change boot loader: "no kernel packages installed"
Upgrade won't change boot loader: "no kernel packages installed"
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: 77030 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2002-10-29 18:00 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-01-03 02:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-29 18:00:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
1. Upgrading from 7.1 to 8.0 complains about "htdig-web" (vague error), ends
abnormally, kills LILO.  "LI" and freeze.  
2. Trying to use GRUB instead is refused by anaconda: message is:
"No kernel packages have been installed on the system.  The boot loader
configuration will not be changed."
3. Return to step 1.  Eliminate install of htdig-web. Repeat forever.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Take a compaq i686 running only Redhat 7.1, using LILO on MBR.
2. Boot the Psyche Redhat 8.0 CD and run through the "upgrade"
3. Use "custom packages" and change packages to taste.  You will find that even
though media is verified, the "htdig-web" package is broken, which abends the
4. Retry the install, this time with no new packages, but asking for GRUB
instead of LILO.  Remember to eliminate the "htdig-web" package or you'll just
repeat #3 forever.
5. Install completes but warns that boot loader has not been changed because "no
kernel packages have been installed".  You can retry this endlessly trying to
install various kernel packages but it won't help.
6. Reboot system normally and freezes with "LI" for LILO.
Notes:  If LILO is installed on a partition above 1024, why was it working
before?  I don't think this is it.  I don't see any LBA option in my BIOS
settings either.

Actual Results:  I think I've discussed this above.  I've tried using text mode
instead of graphic mode:  exactly the same results.  

Expected Results:  What the *fsck* does loading kernel packages have to do with
changing the boot loader?  How can I force GRUB to replace LILO even if I'm not
installing kernel packages?  Even asking for additional kernel packages doesn't
solve the problem.    I can't find any variation of the upgrade procedure that
does. Asking to update LILO instead doesn't work either. Help!

Additional info:

Tried this on two identical computers with similar results. Many times with
minor variations. On one I eventually managed to get GRUB to replace LILO but I
don't know how.  If there's a workaround I'd love to see it.  Yes I checked the
media using linux mediacheck.  Yes I read the FAQ. Yes I have an IQ above 80. 
Yes I have another developer trying with me and we are clueless.
No I don't have another copy of the CD set to try.  By the way the version of
the CD is the "Italian" version called "Psyche", it comes with the italian
"Redhat Magazine".
Comment 1 Need Real Name 2002-10-29 18:06:15 EST
P.S. The cryptic error message I receive every time, "No kernel package has been
installed on the systm. The boot loader configuration will not be changed". This is
a) inexplicable (IMHO)
b) unexplained in the manual
c) not mentioned in the Appendix on boot loaders (nor is the connection between
kernel packages and boot loaders)
d) not mentioned anywhere else.
So let's add this as a doc bug or two, please.
Steve Rapaport.
Comment 2 Jeremy Katz 2002-10-31 14:44:59 EST
What version of the kernel package did you have installed prior to upgrading?
Comment 3 Michael Fulbright 2002-10-31 14:51:14 EST
*** Bug 77030 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2002-10-31 15:20:49 EST
*** Bug 77030 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2003-01-03 02:37:55 EST
Closing due to inactivity.  If you have any further information to add to this
bug, please feel free to reopen it.

Note You need to log in before you can comment on or make changes to this bug.