Bug 769492 - Position of scroll bar jumps
Position of scroll bar jumps
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.4.1
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
https://translate.engineering.redhat....
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-12-20 20:59 EST by Hedda Peters
Modified: 2013-03-03 21:22 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.5.0-alpha-2-SNAPSHOT (20120221-1200)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2011-12-20 20:59:30 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.2.24) Gecko/20111108 Fedora/3.6.24-1.fc14 Firefox/3.6.24

When working on a translation with several pages and when working on the bottom end of one page, the position of the scroll bar jumps when navigating through the entries at the bottom. 

Reproducible: Always

Steps to Reproduce:
1. Open workspace for a document that contains several pages, stay on page 1
2. Scroll all the way to the bottom
3. Open editor for an entry close to the bottom, say 4th last entry.
Actual Results:  
The scroll bar, that I moved all the way to the bottom just before, now jumps up a little, so that the very last entries are now not displayed anymore, you have to scroll down again to make them reappear.

Expected Results:  
Scroll bar should not move

Annoying for 2 reasons:
- The whole page jumps before your eyes, your eyes always have to find their last point of focus again.
- A lot of unnecessary scrolling (jumping up, scrolling down again, entering message, jumping up, scrolling down again...) when translating the last entries of each page.

Using FF 3.6.24 here.
Comment 1 Alex Eng 2012-02-10 01:58:37 EST
Problem doesn't appear in 1.5 due to the layout change.
Comment 2 Ding-Yi Chen 2012-02-20 21:57:09 EST
VERIFIED with Zanata version 1.5.0-alpha-2-SNAPSHOT (20120221-1200)

Note You need to log in before you can comment on or make changes to this bug.