Bug 7695 - Network startup for multiple NICs fails when eth0 disabled
Network startup for multiple NICs fails when eth0 disabled
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-08 22:41 EST by patrick
Modified: 2014-03-16 22:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-31 15:24:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description patrick 1999-12-08 22:41:42 EST
The network startup scripts for starting multiple ethernet devices fails on
any card above eth0 if eth0 is disabled.

sample ifcfg-eth0:

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.1
NETMASK=255.255.255.0
ONBOOT=no

sample ifcfg-eth1

DEVICE=eth1
BOOTPROTO=static
IPADDR=192.168.1.1
NETMASK=255.255.255.0
ONBOOT=yes


The assumption I would have on how this works is by enabling eth1 and
setting it to the specified arguments (and leaving eth0 disabled).  The way
this currently works is that eth1 claims it's starting up at boot time,
however it's really eth0 (you have to move the cable to the other NIC --
pain in the ass).

The problem, I suspect, is in ifup or the init.d network script, however
I'm too lazy to look for it right now.

--
patrick@fezbox.com
Comment 1 Cristian Gafton 2000-01-27 03:26:59 EST
assigned to initscripts
Comment 2 Bill Nottingham 2000-01-31 15:01:59 EST
OK, the problem here is that since the module for whatever
network card is 'eth0' isn't actually loaded, eth0 isn't
assigned by the kernel, and therefore when the module for
eth1 gets loaded, it actually gets assigned eth0.
Comment 3 Bill Nottingham 2000-01-31 15:24:59 EST
Should be fixed in initscripts-4.85-1.

Note You need to log in before you can comment on or make changes to this bug.