Bug 769532 - Eclipse can not load plugins after update to 3.7.1-7
Eclipse can not load plugins after update to 3.7.1-7
Status: CLOSED DUPLICATE of bug 760454
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 03:49 EST by The Source
Modified: 2011-12-21 08:44 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-21 08:44:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description The Source 2011-12-21 03:49:32 EST
Description of problem:
After mentioned update eclipse fails to load it's plugins including cdt, qt (external) and many others. Even in 'About' it shows nothing except himself.
Downgrade to 3.7.1-4 helps. Packages updated together here:
eclipse-platform
eclipse-jdt
eclipse-pde
eclipse-swt
eclipse-rcp
All from 3.7.1-4 to 3.7.1-7

Version-Release number of selected component (if applicable):
3.7.1-7.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Andrew Overholt 2011-12-21 08:44:08 EST
This situation occurs because we had to break a packaging loop by moving a plugin from eclipse-jdt to eclipse-platform.  Unfortunately, without invasive, fragile workarounds, the only way to fix this is to stop Eclipse, mv ~/.eclipse{,.bak2011-12-21} and restart Eclipse.  Some user preferences may be lost and plugins you manually installed (qt, it sounds like) will be gone but you should get the RPM-installed plugins back and you'll be able to re-install anything you previously installed from within Eclipse.

We apologize for this issue and are working on a more robust solution to ensure it never happens again.

*** This bug has been marked as a duplicate of bug 760454 ***

Note You need to log in before you can comment on or make changes to this bug.