Bug 76955 - Yahoo! protocol change crashes GAIM
Yahoo! protocol change crashes GAIM
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gaim (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
http://sourceforge.net/project/showno...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-29 23:51 EST by Brian Baggett
Modified: 2007-04-18 12:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 02:46:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Baggett 2002-10-29 23:51:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When someone from Yahoo's network sends you an instant message, it crashes gaim
completely.  This has been documented by the GAIM folks and 0.59.5 fixes this. 
A new package based on the latest GAIM needs to be released.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open gaim and log in to Yahoo's network
2. Have someone send you an instant message.
3. Restart gaim once it crashes and repeat.
	

Actual Results:  Gaim crashes.

Expected Results:  Gaim should have functioned.

Additional info:

This is not a RedHat bug (it's Yahoo's fault), but repackaging the latest
version of GAIM will fix this.
Comment 1 Ben Levenson 2002-11-04 16:52:37 EST
I've made a couple of RPMS based on 0.59-5, and haven't run into any problems
yet.
Comment 2 Ed Marshall 2002-11-23 16:08:57 EST
There is a related bug in handling of mail notifications with the Yahoo plugin
(apparently there was another minor protocol change), which is solved with the
following commit to gaim CVS:

http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/gaim/gaim/src/protocols/yahoo/yahoo.c.diff?r1=1.43.2.7&r2=1.43.2.8&only_with_tag=gtk1-stable

The RPM that I built of GAIM 0.59.6 with this patch is rock solid for me.
Comment 3 Trever Adams 2003-02-03 16:40:10 EST
78088 is a duplicate of this bug.  Also, because of protocol changes, Gaim
doesn't work with yahoo pretty much at all now.  This is true even for 8.0.93 of
RedHat.  I think you need to package the latest version of gaim and do a release
for 8.0 and 8.0.93 based on that.  It should fix the problem without introducing
more.
Comment 4 Warren Togami 2004-03-17 02:46:40 EST
This should be fixed in rawhide for FC2 test.  We may issue an upgrade
for FC1 after 0.76 at a later date should it prove to solve this and
several other known problems.  Closing...

Note You need to log in before you can comment on or make changes to this bug.