This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 769593 - EAP6 standalone child resources are not discovered
EAP6 standalone child resources are not discovered
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
4.3
Unspecified Unspecified
high Severity urgent (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-12-21 07:31 EST by Libor Zoubek
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:22:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2011-12-21 07:31:28 EST
Description of problem:
When I inventory EAP6 standalone, most of child resources (datasources etc) are not present anymore. The only child present is platform-mbean. On agent bellow exception occurs.

Version-Release number of selected component (if applicable):
Version: 4.3.0-SNAPSHOT
Build Number: 74fe0df

How reproducible:always

  2011-12-21 13:09:15,223 INFO  [ResourceDiscoveryComponent.invoker.daemon-28] (rhq.modules.plugins.jbossas7.BaseProcessDiscovery)- Di
scovered new ...  ResourceType[id=0, name=JBossAS7 Standalone Server, plugin=jboss-as-7, category=Server], /home/hudson/jbas-instanc
es/jboss-eap6-standalone
2011-12-21 13:09:15,224 ERROR [InventoryManager.discovery-1] (rhq.core.pc.inventory.AutoDiscoveryExecutor)- Error in auto discovery
java.lang.ClassCastException: org.rhq.modules.plugins.jbossas7.ManagedASDiscovery cannot be cast to org.rhq.core.pluginapi.inventory
.ResourceDiscoveryComponent
        at org.rhq.core.pc.plugin.PluginComponentFactory.getDiscoveryComponent(PluginComponentFactory.java:94)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.pluginDiscovery(AutoDiscoveryExecutor.java:170)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.call(AutoDiscoveryExecutor.java:104)
        at org.rhq.core.pc.inventory.AutoDiscoveryExecutor.run(AutoDiscoveryExecutor.java:92)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:351)
        at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:178)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:165)
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:267)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:636)
Actual results:
Comment 1 Heiko W. Rupp 2012-01-10 16:03:26 EST
The above exception is already gone since BUG 766284
Comment 2 Heiko W. Rupp 2012-01-24 16:17:33 EST
Managed Servers are now treated differently and live below the host controller
Comment 3 Mike Foley 2012-02-07 14:22:53 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.