Bug 76961 - Anaconda allowed duplicate file system labels?
Anaconda allowed duplicate file system labels?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-30 02:38 EST by Tom Spikes
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Spikes 2002-10-30 02:38:16 EST
(Sorry my english is not very good)
Hi!
Then I install RH 8.0 the fstab is incorrect

This is my original fstab

[root@localhost tmp]# cat /etc/fstab.bak
LABEL=/                 /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda4               swap                    swap    defaults        0 0

and RH is not starting up with this
Then I correct fstab to...

root@localhost tmp]# cat /etc/fstab
/dev/hda3               /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
/dev/hda4               swap                    swap    defaults        0 0

.. RH is starting up correctly.

I have many partitions 

[root@localhost tmp]# fdisk -l /dev/hda

Disk /dev/hda: 255 heads, 63 sectors, 7299 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1      1275  10241406    c  Win95 FAT32 (LBA)
/dev/hda2          1276      6380  41005912+   f  Win95 Ext'd (LBA)
/dev/hda3          6381      7216   6715170   83  Linux
/dev/hda4          7217      7299    666697+  82  Linux swap
/dev/hda5          1276      2550  10241406    7  HPFS/NTFS
/dev/hda6          2551      5738  25607578+   b  Win95 FAT32
/dev/hda7          5739      6380   5156833+   7  HPFS/NTFS

And now it's working.

I have lilo on /dev/hda
and now all is good

that's all

Mirabilis_Jalapa
jalapa@sinkut.com
Comment 1 Bill Nottingham 2002-10-30 22:31:31 EST
What's the error on startup?
Comment 2 Tom Spikes 2002-10-31 06:00:57 EST
Oh it's long error message.
I don't know how I can take it up or is it possible.
But it's something like that

all is starting ok to /clean , 114821/1678792 files 533657/1678792 blocks
Remounting root filesystem readwrite mode
mount: LABEL=/ dublicate -not mounted  [Failed]

and long words error Read-only file system

starting stop to 
Starting system logger:

I need only change on fstab LABEL=/ to /dev/hda3 and rh is starting up.

Mirabilis_Jalapa
Comment 3 Bill Nottingham 2002-10-31 12:17:37 EST
Hm, somehow you have duplicate labels in your setup. Normally anaconda is what
writes labels.
Comment 4 Jeremy Katz 2002-10-31 15:43:26 EST
Do you have any Linux partitions on any other disks?
Comment 5 Tom Spikes 2002-11-01 02:26:04 EST
Yes I have second harddrive and on /dev/hdb have EZ-BIOS because it's my
old hd (from another pc) and I have not time to erase that :) ?
I take it to use then I have time todo that.

Disk /dev/hdb: 255 heads, 63 sectors, 4111 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1   *         1       952   7646908+   b  Win95 FAT32
/dev/hdb2           953      1433   3863632+  83  Linux
/dev/hdb3          1434      1459    208845   82  Linux swap
/dev/hdb4          1460      4981  28290465    f  Win95 Ext'd (LBA)
/dev/hdb5          1460      1507    385528+   b  Win95 FAT32
/dev/hdb6          1508      2527   8193118+   7  HPFS/NTFS
/dev/hdb7          2528      3470   7574616    b  Win95 FAT32
/dev/hdb8          3471      3725   2048256   83  Linux
/dev/hdb9          3726      4981  10088788+   b  Win95 FAT32


Mirabilis_Jalapa
Comment 6 Jeremy Katz 2002-11-05 13:20:57 EST
Did you have the second drive connected when you did your installation?  I'm
pretty sure we should be catching it if so and labeling the new root
appropriately (as something like /1), but I'll have to put together a system to
verify that
Comment 7 Tom Spikes 2002-11-06 00:30:49 EST
Yes it was connected then I install RH.

And RH setup notified the harddrive hdb 
partitiontable is incorrect do U want "setup" (I dont remember what is orginal message) this 
drive?

Mirabilis_Jalapa
Comment 8 Jeremy Katz 2003-01-03 02:39:00 EST
Aha, that means that we didn't recognize the drive and so didn't look for any
labels on it.  Matt, is there a problem with parted and the ezdrive stuff?
Comment 9 Tom Spikes 2003-01-06 06:23:51 EST
I don't know, or I don't remember have parted problems or not, because I wiped my second harddrive and repartitioning it. Now all is good.


Mirabilis_Jalapa
Comment 10 Jeremy Katz 2004-10-04 22:59:04 EDT
This shouldn't be a problem anymore with current releases.

Note You need to log in before you can comment on or make changes to this bug.