Bug 769621 - Provide mavenized jars: org.eclipse.osgi:services and org.eclipse.equinox.http:servlet
Provide mavenized jars: org.eclipse.osgi:services and org.eclipse.equinox.htt...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 08:53 EST by Stanislav Ochotnicky
Modified: 2012-02-11 00:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-11 00:55:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Ochotnicky 2011-12-21 08:53:14 EST
Jetty update needs maven to resolve two eclipse files:
org.eclipse.osgi:services
org.eclipse.equinox.http:servlet

These are part of eclipse, but they do not have symlinks in _javadir. Please add them. There already is org.eclipse:osgi jar in _javadir:
ln -s ../../../../%{_libdir}/%{name}/plugins/org.eclipse.osgi_*.jar osgi.jar

Please do the same for above two artifacts (pom files can probably be downloaded from upstream maven repo) and call %add_maven_depmap on them
Comment 1 Andrew Overholt 2011-12-22 10:19:42 EST
I've found the OSGi services POM but no recent (not since 2007) equinox.http.servlet POM.  I looked here:

http://repo1.maven.org/maven2/org/eclipse/equinox/

Should I just make one myself?
Comment 2 Stanislav Ochotnicky 2011-12-22 11:07:10 EST
That 2007 version (I assume you mean[1]) is actually what jetty is using. So yes, feel free to use that one.

[1] http://repo1.maven.org/maven2/org/eclipse/equinox/http/servlet/1.0.0-v20070606/servlet-1.0.0-v20070606.pom
Comment 3 Andrew Overholt 2011-12-22 16:39:49 EST
Please see if this build solves the problem for you:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3601991

(I ran a scratch build first to verify and it completed successfully:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=3601958)
Comment 4 Alexander Kurtakov 2012-02-11 00:55:26 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.