Bug 769714 - can't escape Plugins window
Summary: can't escape Plugins window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Christian Krause
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-21 20:48 UTC by Hollis Blanchard
Modified: 2012-01-11 20:53 UTC (History)
5 users (show)

Fixed In Version: calibre-0.8.33-2.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-11 20:53:11 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 771049 None None None Never

Internal Links: 771049

Description Hollis Blanchard 2011-12-21 20:48:59 UTC
Description of problem:
There is no way to close the Plugins preferences window (you can't even exit the program).

Version-Release number of selected component (if applicable):
0.8.25-1.fc16

How reproducible:
Always.

Steps to Reproduce:
1. Start Calibre.
2. Click the arrow next to Preferences in the toolbar; select "Get plugins to enhance calibre"
3. In the resulting window, click "Close".
  
Actual results:
A window appears with the following details:

calibre, version 0.8.25
ERROR: Unhandled exception: <b>AttributeError</b>:'Main' object has no attribute 'last_newest_calibre_version'

Traceback (most recent call last):
  File "/usr/lib64/calibre/calibre/gui2/dialogs/plugin_updater.py", line 588, in _close_clicked
    self.gui.recalc_update_label(len(update_plugins))
  File "/usr/lib64/calibre/calibre/gui2/update.py", line 132, in recalc_update_label
    self.update_found('%s%s%d'%(self.last_newest_calibre_version, VSEP,
AttributeError: 'Main' object has no attribute 'last_newest_calibre_version'


Expected results:
The window would close.

Additional info:

Comment 1 Kevin Fenzi 2011-12-24 20:34:44 UTC
This looks like fallout from us disabling the in app update checker. 

We will investigate and see if we can get it fixed up. Thanks for reporting it.

Comment 2 Fedora Update System 2011-12-31 00:56:31 UTC
calibre-0.8.33-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/calibre-0.8.33-2.fc16

Comment 3 Fedora Update System 2011-12-31 20:24:15 UTC
Package calibre-0.8.33-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing calibre-0.8.33-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17589/calibre-0.8.33-2.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-01-11 20:53:11 UTC
calibre-0.8.33-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.