Bug 769766 - tcpdump on wlan0 crashes system
Summary: tcpdump on wlan0 crashes system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-22 06:29 UTC by Stuart D Gathman
Modified: 2012-01-24 07:57 UTC (History)
10 users (show)

Fixed In Version: kernel-3.2.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-24 07:57:14 UTC
Type: ---


Attachments (Terms of Use)
photo of kernel oops screen (2.44 MB, image/jpeg)
2011-12-22 18:54 UTC, Stuart D Gathman
no flags Details
wpa_check_key_NULL.patch (703 bytes, text/plain)
2012-01-05 08:13 UTC, Stanislaw Gruszka
no flags Details

Description Stuart D Gathman 2011-12-22 06:29:11 UTC
Description of problem:
black screen of death from tcpdump (or wireshark)

Version-Release number of selected component (if applicable):
kernel-3.1.5-6.fc16.i686

How reproducible:
tcpdump -i wlan0 -w ipp.tr -s 1500

Steps to Reproduce:
1.
2.
3.
  
Actual results:
system crash

Expected results:
normal packet trace

Additional info:
wlan0 is run by rt73usb, which works fine when not attempting to trace.
The oops is in some usb_* calls.
I realize a kdump would be needed here, but system-config-kdump doesn't work on Fedora 16, and I haven't got a manual configuration to work yet (not even with sysrq-trigger, the system crashes, but no crash kernel) see bug#769763

Comment 1 Neil Horman 2011-12-22 12:29:15 UTC
Can you provide a stack trace as recorded from a serial console?

Comment 2 Stuart D Gathman 2011-12-22 18:18:15 UTC
This is the only computer I have with a serial port.  But I can take a picture of the stack trace on the console and attach it.  Will do that in a little while.

Comment 3 Stuart D Gathman 2011-12-22 18:54:24 UTC
Created attachment 549230 [details]
photo of kernel oops screen

Comment 4 Stuart D Gathman 2011-12-22 20:58:39 UTC
I have managed to collect a kdump vmcore.  What should I extract from it to attach?  I am a newbie to crash.

Comment 5 Stuart D Gathman 2011-12-22 21:20:50 UTC
It seems that crash is broken on f16 also: bug#742260

Any other way to extract useful info from vmcore?

Comment 6 Stanislaw Gruszka 2011-12-31 11:26:58 UTC
I have rt73usb, I'll see if I can reproduce that locally ...

Comment 7 Stuart D Gathman 2012-01-03 14:34:33 UTC
Retested with kernel-3.1.6-1.fc16.i686
Still crashes, got new vmcore.  The "crash" utility still crashes.

Comment 8 Stanislaw Gruszka 2012-01-05 08:13:44 UTC
Created attachment 550844 [details]
wpa_check_key_NULL.patch

I was able to reproduce, and this patch prevent the crash. But I have to investigate issue a bit more to find out why key is NULL and to see if perhaps some better fix for the problem exist.

Comment 9 Stuart D Gathman 2012-01-10 03:30:13 UTC
I installed an Atheros Communications Inc. AR2413 802.11bg NIC, and tcpdump works with that.  I think this means that the problem is with rt73usb, not wireless in general, despite the patch in comment#8 being for wpa.c.

Comment 10 Stanislaw Gruszka 2012-01-10 06:15:54 UTC
That's way I'm still looking at that problem, I'm not sure if rt73usb driver do something wrong or mac80211 should be more resistant for rt73usb data.

Comment 11 Stanislaw Gruszka 2012-01-11 14:45:59 UTC
I think this should be fixed in mac80211.

I posted fix here:
http://marc.info/?l=linux-wireless&m=132627059504821&w=2

Comment 12 Josh Boyer 2012-01-11 16:18:20 UTC
(In reply to comment #11)
> I think this should be fixed in mac80211.
> 
> I posted fix here:
> http://marc.info/?l=linux-wireless&m=132627059504821&w=2

I added this to all 3 branches.  Should be in the next respective builds of each.  Thanks!

Comment 13 Fedora Update System 2012-01-13 20:58:01 UTC
kernel-3.1.9-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.9-1.fc16

Comment 14 Fedora Update System 2012-01-15 20:11:20 UTC
kernel-3.1.9-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Stanislaw Gruszka 2012-01-15 20:30:50 UTC
We experiment with compat-wireless package. That mean there are two drivers installed, one in /lib/modules/`uname -r`/drivers/net/wireless/ second one in
/lib/modules/`uname -r`/backports/drivers/net/wireless/ .  By default compat-wireless (backport) modules are used, which does not include that fix AFAIK.

To use in kernel modules, should be enough to remove "backport" entry from  /etc/depmod.d/dist.conf and reboot the system.

Comment 16 Josh Boyer 2012-01-15 21:24:28 UTC
(In reply to comment #15)
> We experiment with compat-wireless package. That mean there are two drivers
> installed, one in /lib/modules/`uname -r`/drivers/net/wireless/ second one in
> /lib/modules/`uname -r`/backports/drivers/net/wireless/ .  By default
> compat-wireless (backport) modules are used, which does not include that fix
> AFAIK.
> 
> To use in kernel modules, should be enough to remove "backport" entry from 
> /etc/depmod.d/dist.conf and reboot the system.

Sigh.  You are right.  Knowing if and when we have to patch the backported drivers is a bit non-obvious.  I'll reopen this for now and get it fixed, especially since we use those by default.

Comment 17 Josh Boyer 2012-01-15 21:26:47 UTC
OK.  Should be fixed now.  THIS TIME WITH FEELING!

Comment 18 Fedora Update System 2012-01-23 18:32:50 UTC
kernel-3.2.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.2.1-3.fc16

Comment 19 Fedora Update System 2012-01-24 01:44:57 UTC
Package kernel-3.2.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.2.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0876/kernel-3.2.1-3.fc16
then log in and leave karma (feedback).

Comment 20 Fedora Update System 2012-01-24 07:57:14 UTC
kernel-3.2.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.