Bug 769798 - fence_vmare_soap is slower than fence_vmware
Summary: fence_vmare_soap is slower than fence_vmware
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents
Version: 6.2
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Marek Grac
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 836654 868183 872620
TreeView+ depends on / blocked
 
Reported: 2011-12-22 09:56 UTC by Timothy
Modified: 2018-11-29 21:24 UTC (History)
11 users (show)

Fixed In Version: fence-agents-3.1.5-21.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 836654 868183 (view as bug list)
Environment:
Last Closed: 2013-02-21 07:41:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0286 normal SHIPPED_LIVE fence-agents bug fix and enhancement update 2013-02-20 20:36:45 UTC
Red Hat Knowledge Base (Solution) 89183 None None None Never
Red Hat Knowledge Base (Article) 108933 None None None 2012-09-21 14:44:00 UTC
Red Hat Bugzilla 836654 None None None Never

Internal Links: 836654

Description Timothy 2011-12-22 09:56:57 UTC
Description of problem:
My test shows that I have to wait approximately 15 Seconds where as when I use fence_vmware, I get a result immediately:


Version-Release number of selected component (if applicable):
3.1.5-10.el6

How reproducible:
# time fence_vmware_soap -o status -a 10.1.1.1 -l vm_stonith -p '***pwd***' -v -U 4211b0a1-bb56-edc2-2c77-fc594ceab28f -u 443 -z
Status: ON
real    0m15.832s

# time fence_vmware -o status -a 10.1.1.1 -l vm_stonith -p '***pwd***' -n "test1"
Status: ON
real    0m1.422s

Actual results:
fence_vmware_soap needs much more time to complete

Expected results:
answer time is in same range

Comment 21 Marek Grac 2012-10-25 09:07:45 UTC
Unit test:

Check if status is working correctly. It is possible to test if fencing response is better then in previous version but this is hard to measure. 

fence_vmware_soap -z -l LOGIN -p PASS -a IPADDR -n VMNAME

Comment 26 errata-xmlrpc 2013-02-21 07:41:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0286.html


Note You need to log in before you can comment on or make changes to this bug.