Bug 76987 - No sound (other than system beeps) since upgrade to RH 8.0
No sound (other than system beeps) since upgrade to RH 8.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-30 12:08 EST by Travis Saling
Modified: 2007-04-18 12:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 08:34:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Saling 2002-10-30 12:08:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021023

Description of problem:
I did a clean install of RH 8.0 (reformatting the disk) on my computer, which
was running RH 7.3 without problems. Ever since the install my system cannot
play sounds, other than system beeps of course (so it's not my speakers). This
includes when playing games, running XMMS, using RealPlayer, or just running "play".

I grabbed sndconfig using up2date to see if that would help. It seems to
recognize my card - it reports back "Model: ESS Technology\ES19835 Maestro-3i
PCI Audio Accelerator". When it tries to play its test sound, though, I get a
loud "click" through the speakers, and then nothing - sndconfig just hangs.

When trying to play sounds I've noticed that esd starts to eat up a lot of CPU
time. This continues until I 'killall esd'.

Running lsmod gives the following:
$ lsmod
Module                  Size  Used by    Not tainted
maestro3               30896   2
soundcore               6532   2 [maestro3]
ac97_codec             13416   0 (autoclean) [maestro3]
parport_pc             19108   1 (autoclean)
lp                      8996   0 (autoclean)
parport                37152   1 (autoclean) [parport_pc lp]
autofs                 13348   1 (autoclean)
ds                      8712   2
yenta_socket           12960   2
pcmcia_core            54784   0 [ds yenta_socket]
xircom_cb               8968   1
ipt_REJECT              3736   2 (autoclean)
iptable_filter          2412   1 (autoclean)
ip_tables              14936   2 [ipt_REJECT iptable_filter]
ide-scsi               10512   0
scsi_mod              107240   1 [ide-scsi]
ide-cd                 33608   0
cdrom                  33696   0 [ide-cd]
nls_iso8859-1           3516   4 (autoclean)
nls_cp437               5148   4 (autoclean)
vfat                   13084   4 (autoclean)
fat                    38712   0 (autoclean) [vfat]
mousedev                5524   1
keybdev                 2976   0 (unused)
hid                    22244   0 (unused)
input                   5920   0 [mousedev keybdev hid]
usb-uhci               26188   0 (unused)
usbcore                77024   1 [hid usb-uhci]
ext3                   70368   2
jbd                    52212   2 [ext3]



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Turn on computer.
2. Try to play a sound that's not a system beep.
3.
	

Actual Results:  Nothing.

Expected Results:  Sound should play.

Additional info:

I'm running RH 8.0 on a Dell Inspiron 3800 laptop, with a Maestro ESS sound
card. Sound worked fine in previous versions of RH 7.1 - 7.3.

Although I reported this against esound, I really don't know if that's the
culprit. It could be the kernel modules I suppose.
Comment 1 Travis Saling 2002-10-30 17:16:20 EST
More information. I grabbed kernel 2-4.19 from kernel.org, applied the ac-4
patch to it, and built that kernel (with Maestro3 support still modular).
Booting from that kernel (with no changes to esound settings etc.) solves the
problem - so I'm pretty sure it is NOT an esound problem. I'm changing the
component to "kernel" (if bugzilla allows me to do that).
Comment 2 Need Real Name 2002-11-07 09:07:38 EST
I have observed the same bug on my Dell Inspiron 8100.

Additionally, I have been able to verify that sound works with kernel-2.4.18-14,
but not with kernel-2.4.18-17.8.0
Comment 3 Arjan van de Ven 2002-11-07 09:13:25 EST
http://people.redhat.com/arjanv/testkernels  <-- proposed fix
Comment 4 Need Real Name 2002-11-07 09:48:18 EST
The sound worked with kernel-2.4.18-17.2.i686.rpm!
Comment 5 Travis Saling 2002-11-08 02:04:00 EST
The test kernel has solved the sound problem for me as well. At first glance
everything seems to be working (no new problems introduced by the test kernel,
in other words).

Note You need to log in before you can comment on or make changes to this bug.