Bug 769881 - tree_repos -> os_repos broke your own snippets.
tree_repos -> os_repos broke your own snippets.
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bill Peck
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 10:54 EST by Arlinton Bourne
Modified: 2012-09-13 10:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-22 11:42:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Arlinton Bourne 2011-12-22 10:54:03 EST
So you guys decided to change tree_repos to os_repos and change the syntax. In doing that you've broken a few of your own scripts as well.

Here are two snippets that still reference tree_repos:
./anaconda_repos:#if $getVar('tree_repos','') != ''
./anaconda_repos:#for $repo in $getVar('tree_repos','').split(':')
./rhts_post:#set $tree_repos = $getVar('tree_repos','')
./rhts_post:#if $tree_repos != ''
./rhts_post:#if $tree_repos.find("http://") != -1
./rhts_post:#for $repo in $getVar('tree_repos','').split($split)
Comment 1 Bill Peck 2011-12-22 11:06:08 EST
Hi Arlinton,

Sorry, I didn't know you were using those.  We still have tree_repos because some distros in cobbler may still have that data.  going forward we are only populating os_repos, debug_repos, etc..
Comment 2 Arlinton Bourne 2011-12-22 11:26:13 EST
The $tree_repos variable is empty. Also these scripts are shipped with cobbler and thus is maintained by you guys. You probably might want to fix it.
Comment 3 Bill Peck 2011-12-22 11:42:27 EST
Yes the tree_repos is empty for newly processed distros but not for old distros.

Its left there in case the customer has old distros with tree_repos defined.  Thats all.

Note You need to log in before you can comment on or make changes to this bug.