Bug 769972 - initramfs avc denied getattr for systemd /var/run
initramfs avc denied getattr for systemd /var/run
Status: CLOSED DUPLICATE of bug 807952
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 16:01 EST by John Reiser
Modified: 2013-07-04 09:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-13 05:14:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2011-12-22 16:01:04 EST
Description of problem: Upon boot of DVD for install of rawhide for Fedora 17, then syslog and output from dmesg shows a selinux complaint for denied getattr by systemd on /var/run.


Version-Release number of selected component (if applicable):
lorax-17.1-1.fc17.x86_64
dracut-014-9.git20111215.fc17.noarch.rpm
systemd-37-4.fc17.x86_64.rpm


How reproducible: every time


Steps to Reproduce:
1. build, burn, boot DVD for install of rawhide for Fedora 17.
2.
3.
  
Actual results:
20:12:23,807 NOTICE kernel:[   62.491456] type=1400 audit(1324584731.157:3): avc:  denied  { read } for  pid=1 comm="systemd" name="run" dev=dm-0 ino=73761 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:file_t:s0 tclass=lnk_file

[   63.027437] type=1400 audit(1324584731.693:4): avc:  denied  { getattr } for  pid=1 comm="systemd" path="/var/run" dev=dm-0 ino=73761 scontext=system_u:system_r:init_t:s0 tcontext=system_u:object_r:file_t:s0 tclass=lnk_file


Expected results: no complaints


Additional info:
Comment 1 Miroslav Grepl 2012-04-13 05:14:20 EDT

*** This bug has been marked as a duplicate of bug 807952 ***

Note You need to log in before you can comment on or make changes to this bug.