Bug 76999 - chat program produces incomplete logs
Summary: chat program produces incomplete logs
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-30 19:43 UTC by Thomas J Pinkl
Modified: 2015-01-08 00:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-16 16:13:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas J Pinkl 2002-10-30 19:43:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
I'm using a "chat -v -s -S" command to capture chat's output to my own
log file (ie. not syslog).  Sometimes the log will be incomplete.  It
may be missing parts from the middle of the conversation or the entire
log may be empty.

When I looked at the 'chat' source I saw that it mixes I/O modes.  It 
uses both "write(2,...)" and "fprintf(stderr,...)".  I believe this is
the cause of the logging problems.

I patched my source to 'chat' such that it doesn't mix I/O methods.
Since then, the logs have been complete.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. run logs of pppd sessions
2.
3.
	

Additional info:

I submitted a patch to the "linux-ppp" list on Apr 19, 2002.  The 
subject line was "chat timestamp patch".

Comment 1 Thomas Woerner 2004-08-16 16:13:02 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.


Note You need to log in before you can comment on or make changes to this bug.